Pihole hammered when record exists in /etc/pihole/custom.list

The issue I am facing:
When I leverage a Local DNS record, for example to my pi hole, leveraging a domain that I own but a non existing subdomain nonexistantsub.mydomain.tld for example. I've given pi-hole a local DNS record of pihole.nonexistantsub.mydomain.tld. When leveraging that DNS name to reach the pi hole I can have my client get RATE_LIMIT impacted for example by tailing the pihole.log.

Details about my system:
Fresh docker install for home network leveraging Tag 2023.01.10. As mentioned above I've configured local dns zones for internal systems as an override so I don't have to keep remembering IP's and can leverage a nginx proxy to host many docker containers on port 80 (all getting a new local dns entry).

What I have changed since installing Pi-hole:
Nothing at this point, fresh install.

Checkout below:

Below worked for me:

pi@ph5b:~ $ sudo nano /etc/dnsmasq.d/99-my-settings.conf
pi@ph5b:~ $ pihole restartdns
  [✓] Restarting DNS server

I'm surprised I didn't find that when I was searching, thanks for sharing. I'm also a bit surprised that a default no-cache is set, but I do like the flexibility.

Solved now?

Default OOTB cache should be:

pi@ph5b:~ $ dig +short @localhost chaos txt cachesize.bind

Yeah, it is solved for me, I've placed mine at 60 seconds.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.