pihole-FTL won't start?


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

service pihole-FTL start should start the service…

Actual Behaviour:

root@raspberrypi:~# service pihole-FTL start

Stopped

rm: cannot remove `/var/run/pihole/FTL.sock’: No such file or directory
FTL started!

–> But the service isn’t running… I already tried a repair of pihole and nothing changed. Can anyone please give me a hint?

Debug Token:

7zd4qjzftn


#2

What’s the output of sudo systemctl status pihole-FTL.service ?


#3

Hi RamSet,

i can give you the following:

service pihole-FTL status

/etc/init.d/pihole-FTL: line 73: status: command not found

As systemctl isn’t available on my raspi.


#4

This is a known issue that you can read about more here:

What’s the output of pihole -v and cat /etc/os-release


#5

RamSet Moderator
June 14

laserbrain:

/etc/init.d/pihole-FTL: line 73: status: command not found

This is a known issue that you can read about more here:

pihole-FTL is working, but webmin says the service is not running Help

Despite nice weather today (sunny, 22°C), I finished coding the systemd unit. More details can be found here:

What’s the output of pihole -v and cat /etc/os-release


#6

Okay, you are right, it’s seems to be running:

root@raspberrypi:~# ps fax | grep pihole*

32414 pts/0 S+ 0:00 _ grep pihole*

24459 ? Sl 0:33 /usr/bin/pihole-FTL

root@raspberrypi:~# pihole -v

Pi-hole version is v3.3.1 (Latest: ERROR)

AdminLTE version is v3.3 (Latest: v3.3)

FTL version is v3.0 (Latest: v3.0)

root@raspberrypi:~# cat /etc/os-release

PRETTY_NAME=“Raspbian GNU/Linux 7 (wheezy)”

NAME=“Raspbian GNU/Linux”

VERSION_ID=“7”

VERSION=“7 (wheezy)”

ID=raspbian

ID_LIKE=debian

ANSI_COLOR=“1;31”

HOME_URL=“http://www.raspbian.org/

SUPPORT_URL=“http://www.raspbian.org/RaspbianForums

BUG_REPORT_URL=http://www.raspbian.org/RaspbianBugs

But I’m still not seeing any action in the webinterface of pihole about dns requests…


#7

This version of Raspbian is End of Life and no longer supported with the Pi-hole.

You would have to update to a newer (Stretch - Latest) version.