pihole-FTL keeps stopping


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

“pihole-FTL” service should keep running.

Actual Behaviour:

I was having an issue with “illegal repeated keyword at line 33 of /etc/dnsmasq.d/01-pihole.conf” and finally realized that I had made a copy of 01-pihole.conf in that same directory. Once I deleted the “bkp” file, “sudo service pihole-FTL restart” worked. But, over the last 24 hrs or so, “pihole-FTL” has stopped twice. I ran the debug after restarting pihole-FTL.

Debug Token: 8w6bzro7ap


#2

I just found this:

pi@raspberrypi-1:/var/log$ sudo cat /var/log/lighttpd/error.log
2019-02-10 06:25:02: (server.c.1534) logfiles cycled UID = 0 PID = 31795 
2019-02-10 10:24:34: (mod_fastcgi.c.2543) FastCGI-stderr: PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /var/www/html/admin/scripts/pi-hole/php/FTL.php on line 41

pi@raspberrypi-1:/var/log$


#3

Your debug log is showing a shared memory error. Try these commands to clear shared memory and restart FTL:

sudo rm /dev/shm/FTL*
sudo service pihole-FTL restart

#4

I did that and everything started working again.

Today, at about 10:42AM CST my other raspberry pi also stopped with shared memory errors. I used the same two commands to get it working again.

Is this a bug? If so, is there a work-around yet?


#5

It is not a bug that I am aware of. It happens with FTL is launched as root user, causing the shared memory files to be created under root. Then if FTL crashed, when started as pihole user, there is no permission to clean up the memory files.

Ensure that when you stop, start or restart FTL you only do so using the service command, never directly with a call to FTL.


#6

Share the errors you see so we can help debug.


#10

I woke up this morning with no internet access. Both raspberry pi’s (pihole servers) were not processing DNS.

#2 came back with the following two commands:
sudo rm /dev/shm/FTL*
sudo service pihole-FTL restart

#1 required a reboot

Token for #1: l3z7t0dbnh
Token for #2: 55sxkpo64d

As a side note, I never had any of these issues until the 4.2 update.


#11

On #2, what are the lines in /var/log/pihole-FTL.log immediately preceding the “FTL crashed” line - provide the previous 20 lines please.


#12

There are no previous lines.

#1 just crashed. I uploaded the “pihole -d” file the token is: 0deyvkiako


#13

To help us understand the problem, please provide the section of that pihole-FTL log from 20 lines prior to the crash and through all the output following the crash that it says to send to the developers. Thanks.


#14

I did reply to your request. There are not previous lines in the “.log” file or the “.log.1” file. I can’t explain why but that’s all I have.


#15

OK. Thanks.


#16

#1 has crashed again and pihole-FTL stopped. Should I open a new topic or continue this one?

#1 new token for “pihole -d” is: 5o8qjejmom

Meanwhile I’m prepping a fresh SD card for #1 with raspian, cloudflare DoH, & pihole. I won’t do this until I hear that the uploads aren’t telling us anything.

What is the best way for me to send you the output for “cat /var/log/pihole-FTL.log” (I ran this prior to:

  • sudo rm /dev/shm/FTL*
  • sudo service pihole-FTL restart
  • pihole -d

#17

You can post the log output here. Unless it’s huge, it won’t exceed the post limits.


#18

We are working on some fixes for the issues in v4.2.1, it would be helpful if you could test if you still experience these issues on this branch:

pihole checkout ftl tweak/overhaul_overTime

#19

We can close this thread. I’ve decided against continuing down this rabbit hole. I’m not knowledgeable enough to running “pihole checkout…”. I’ve done a clean install on #2.

For some reason, #1 is behaving well; knock wood.