pihole-FTL is working, but webmin says the service is not running

Hi all,

This is my first post - but I've recently deployed Pi-hole as my DHCP and DNS service for home.
I've also enabled this new FTLDNS option.

Some feed back - pihole-FTL is working, but webmin says the service is not running.
[USER@SERVER ~]# systemctl status pihole-FTL
● pihole-FTL.service - LSB: pihole-FTL daemon
Loaded: loaded (/etc/init.d/pihole-FTL; bad; vendor preset: enabled)
Active: active (exited) since Wed 2018-03-28 19:51:33 BST; 4min 50s ago
Docs: man:systemd-sysv-generator(8)

Also, and I don't know if this is expected, but running pihole -up now displays an error trying to update FTL: -

[USER@SERVER ~]# sudo pihole -up
[i] Checking for updates...
[i] Pi-hole Core: up to date
[i] FTL: update available

[i] FTL out of date

[i] FTL Checks...
[i] Detecting architecture...
[eK [✓] Detected x86_64 architecture
[i] Checking for existing FTL binary...
[i] Downloading and Installing FTL...transferred...
[eK [✓] Downloading and Installing FTL

fatal: unable to access 'https://github.com/pi-hole/AdminLTE.git/': Could not resolve host: github.com
[i] Web Interface: up to date

[i] FTL version is now at
[i] Starting pihole-FTL service...
[eK [✓] Starting pihole-FTL service
[i] Enabling pihole-FTL service to start on reboot...
[eK [✓] Enabling pihole-FTL service to start on reboot

Please send us the token generated by

pihole -d

or do it through the Web interface:

1 Like

Thanks for your assistance Jacob.

My debug code is: pptd17iasx

What does systemctl status dnsmasq return?

1 Like

● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
Loaded: loaded (/lib/systemd/system/dnsmasq.service; disabled; vendor preset: enabled)
Drop-In: /run/systemd/generator/dnsmasq.service.d
└─50-dnsmasq-$named.conf, 50-insserv.conf-$named.conf
Active: inactive (dead)

I'm not seeing the same FTL download issue now after upgrading to: -
Pi-hole Version vDev (FTLDNS, v3.2.1-148-g82d5afe) Web Interface Version vDev (FTLDNS, v3.2.1-121-gd921263) FTL Version vDev (FTLDNS, vDev-003371f)

Webmin still sees the service as not running though. I've gone through the service and manually done the check myself and I get this as the result (when it is running): -
42258 ? Sl 0:00 /usr/bin/pihole-FTL

All I can assume is Webmin isn't able to do part of the check (permissions?)... not sure.

did you change /etc/hosts localhost into something else than localhost?

1 Like

No, that is the first line in my hosts file. localhost

@DL6ER asked me in a diferent post:

Status - DNS service not running but it actually runs - #12 by DL6ER

What does that command return ?

"DNS service is running"

and under Setting / System, you don't see the FTL info like this:


1 Like

No, I do. It's all working. Just the checks for it (at least via webmin) are suggesting it is not running.

In webmin, When I try and "start" (not restart) I get: -

FTL started!'

If I click "status" I get: -
Executing /etc/init.d/pihole-FTL status ..
/etc/init.d/pihole-FTL: line 78: status: command not found

OK I've fixed that line 78 error by adding: -
Line14: . /lib/lsb/init-functions

And replacing line 79
from: status pihole-FTL
to: status_of_proc pihole-FTL

I replaced the code at line 78 with this:

    if ps -p "$(get_pid)">/dev/null 2>&1 ; then
    echo "FTLDNS is Active"
    echo "FTLDNS is not active"

I don't know if that will work in your case.

I can confirm though that asking the status via /etc/init.d/pihole-FTL was broken on my side too.

I'm aware of this problem and have a rewrite of the service file from init.d to systemd planned for the near future (ideally this weekend, but it seems that the weather might be too good for this goal :slight_smile: ).

This is not always available, we had it in there sometime > 1 year ago and it wasn't found on most user's systems. As I said, we're aware of that init.d scripts are ancient by now, but we needed them as FTL started back on Debian Wheezy.

If we find a good solution together that fixes our current init.d script - good. If we are able to upgrade to a systemd unit with Pi-hole v4.0 - even better.

1 Like

Thanks DL6ER - not a problem, enjoy the weather if you can :slight_smile:

Despite nice weather today (sunny, 22°C), I finished coding the systemd unit. More details can be found here:

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.