Pihole Failing to Resolve Other Hosts

Please follow the below template, it will help us to help you!

Expected Behaviour:

DNS should resolve when my DHCP system provides the IP of my pihole to clients.

Actual Behaviour:

Clients cannot resolve any hosts; Pihole only works on the Raspberry Pi I installed pihole on

Debug Token:


From your debug log, Pi-Hole is processing a lot of queries, likely more than generated by the Pi itself. Typically when we see 2 clients, one is the Pi and the other might be the router.

   [2020-01-26 17:59:36.824 1262] Imported 33395 queries from the long-term database
   [2020-01-26 17:59:36.825 1262]  -> Total DNS queries: 33395
   [2020-01-26 17:59:36.825 1262]  -> Cached DNS queries: 218
   [2020-01-26 17:59:36.825 1262]  -> Forwarded DNS queries: 33023
   [2020-01-26 17:59:36.825 1262]  -> Exactly blocked DNS queries: 154
   [2020-01-26 17:59:36.825 1262]  -> Unknown DNS queries: 0
   [2020-01-26 17:59:36.825 1262]  -> Unique domains: 445
   [2020-01-26 17:59:36.825 1262]  -> Unique clients: 2
   [2020-01-26 17:59:36.825 1262]  -> Known forward destinations: 2

Let's check who is using Pi-Hole. Please post the output of this command from the Pi terminal:

echo ">top-clients" | nc localhost 4711

Next, we check from a network client to see which DNS it is using. From one of the network clients running Windows, Linux or MacOS, run these commands directly from the command prompt or terminal on that client and post the output:

nslookup pi.hole

nslookup pi.hole

It does show the Router as well as the Pi:

pi@KissMyPiHole:~ $ echo ">top-clients" | nc localhost 4711
0 34577 
1 693 localhost
2 1 raspberrypi

NSLookup looks good as well:

pi@KissMyPiHole:~ $ nslookup pi.hole

Name:	pi.hole

When my DHCP vends the pi.hole (.101) nothing resolves. I don't have my router pointing to the pihole either for its local DNS.

I'm using DD-WRT. How can I take screen snips (capture) in the Linux GUI?

Perhaps I don't fully understand the problem you are seeing. "Clients cannot resolve any hosts".

The debug log shows that the Pi-Hole received more than 33K queries in 24 hours, most of them from the router. The router is the DHCP server in your setup, and almost all the queries are shown as coming from the router. The router isn't making all those DNS requests - what you are likely seeing is the queries from all the connected clients appearing to come from the router.

Please clarify the problem you are experiencing and why Pi-Hole only works on the Pi you installed it on.

Also, please post the outputs of these commands from the Pi terminal:

echo ">top-domains" | nc localhost 4711

echo ">top-ads" | nc localhost 4711

When I run nslookup on a client, it shows my router as the DNS server which cannot find nor can it resolve pi.hole. Basically, my router doesn't see the Pihole.




As you can see from my DD-WRT settings, I don’t have the Pihole set.

If I change Local DNS to, nothing resolves and I can’t surf the web or do anything.

If I change the Static DNS 1 to, nothing resolves and I can’t surf the web or do anything.

Currently, the top clients are not incrementing any longer either as I am not surfing on the Pihole device and nothing else seems to know it exists since if I put the .101 IP in for DNS, nothing resolves.


Where should I have the .101 set? For the Static DNS 1 and/or the Local DNS for my Router?

Thank you VERY much for this assistance.

I removed Forced DNS Redirection and added .101 as the Static DNS. Some resolve VERY SLOWLY and others still fail. It appears nearly all are attributed to the Router as you can see the count increments.


In this forum, it works best to copy and paste text output into a reply. Your screen shots are small and difficult to read. You also don't want to blank out the server - that's a part of the output we need to see.

It must have worked at one time, since there was quite a bit of DNS traffic going to the Pi-Hole. Something must have changed between then and now.

You may have to experiment a bit, but it looks like in both places. Have you read the manual for this router and firmware?

When you had the router pointed at the Pi-Hole DNS, did you reboot the router and renew the DHCP leases on all the connected clients? If you don't get them a fresh lease, they won't get the new DNS information.

Sorry, I'm bouncing between systems and using email on a Windows system as it takes screen shots.

Basically, I'm in the position that when I put the .101 IP in the Static DNS 1 spot, DNS won't resolve or it resolves very slowly and intermittently.

I have Ethernet and WIreless enabled. Is it possible there's a conflict in pihole with that?

I don't know, not being familiar with all the details of your network and router.

Here's a quick way to split the problem - manually assign a client to use Pi-Hole DNS (and only Pi-Hole DNS). If that client uses Pi-Hole smoothly, then the problem is in your router configuration.

Thanks JFB, that's a good idea. I'll set a static DNS to .101 on a Windows system and isolate if this is the router or Pi-hole. Have a good night.

Good call. Looks like there's a router issue as when I set a client to .101, it works perfectly. Thanks for your help. Looks like a software issue in my DD-WRT.

I don't think it is as much a software issue as a settings issue. I would go on the DD-WRT forums and see how they set up custom DNS.

I rebooted my router and everything lit up like a Christmas tree. I am 100% operational. Thanks much @jfb.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.