Pihole doesn't seem to be enabled on my computer

I setup my pihole yesterday and found it working on my phone. However, when I use my computer, pihole doesn’t seem to block anything. I disabled ipv6, put in the DNS server of my computer to my pihole DNS, and put the DNS of the pihole to my router’s DNS.

Expected Behaviour:

Pihole blocks ads

Actual Behaviour:

Pihole doesn’t block ads

Debug Token:

gqrshe37w3

Are you able to resolve pi.hole on that machine? nslookup pi.hole

Make sure you are only using Pi-hole for DNS.

Yes, I am able to resolve pi.hole on this machine. Also, I have set the DNS server of the router to the pi.hole machine.

What specifically are you seeing? No traffic to the Pi-Hole from this client, some traffic but still seeing ads, ?

Tail the pihole log withpihole -t from the Linux terminal and visit a new website you haven’t visited before or recently on that client (so it won’t be cached). You should see a burst of traffic to Pi-Hole from that client.

Alright, it seems that the pi-hole is actually working and I’m kind of a dumbass. My concern was mainly having ads shown up on youtube.com and all the “new sites” I visited did not have any ads. I cleared the cache of my computer and that appears to be the solution.

Glad it’s working. You will still see some ads on YouTube, since they serve the ads from the same domains as the content. It is difficult to block the domains while not interfering with the content.

Do you recommend having some sort of browser adblock in addition to pi-hole? Will it impact the network traffic at all?

Some users use browser based blockers. uBlock Origin seems popular.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.