Pihole DNS not working through LAN, but does through Openvpv after hardware upgrade

Hi Pi-Hole,

Between christmas and new years I have exchanged the old pc for a new one, leaving the linux installation intact (Buster). Doing this broke a lot of things, primarily because the internet adapter changed from enp2s0 to eno1. I spend quite some time getting the server to work… I then also broke the VPN tunnel through pihole and today finally got to fixing this. I also just realized pihole is also no longer blocking ads through my main pc (secondary set to 8.8.8.8) and after forcing it to use the IP of the pi-hole system I cannot seem to resolve the DNS.

The interesting part is that tunneling with openvpn does work, but accessing on a local network seems to fail.

I’m not confident this is a fault on pihole’s part, but currently only pihole seems to not work (plus I spend like 3 hours already yawn).

Can you perhaps give me some pointers what I need to kick to get pihole to work on lan again?

Debug Token:

jxz8dbqnct

I should note that I changed the port from 80 to 81, diyHue doesn’t want to move.

First, run below one and select Reconfigure to run through all the settings after your changes:

pihole -r

Second, check network interfaces available:

ip l

ip a

And check interface configured for Pi-hole:

grep PIHOLE_INTERFACE /etc/pihole/setupVars.conf

And how Pi-hole is configured to listen to these interfaces:

grep DNSMASQ_LISTENING /etc/pihole/setupVars.conf

If configured to lets say only listen on the eth0 or wlan0 interface, querying Pi-hole’s DNS on the other interfaces, like for example the VPN’s tun0 IP, will fail.

To have Pi-hole answer DNS queries on all interfaces, change below Pi-hole setting on the web GUI:

Test on a client PC with the nslookup tool (Windows/Linux/MacOS).
Below 10.0.0.2 = Pi-hole @ my place.

C:\Users\deHakkelaar> nslookup pi.hole 10.0.0.2
Server:  noads.dehakkelaar.nl
Address:  10.0.0.2

Name:    pi.hole
Address:  10.0.0.2

Here’s the result of these commands:


It seems setupVars.conf points to the wrong, well, “not correctly to all interfaces”.

nslookup fails no matter what from client

Edit: Changing it to eno1 and restarting the DNS client didn’t affect anything as far as I can see.

Output looks good.
Maybe a rogue config file messing things up:

sudo grep -v '^#\|^$' -R /etc/dnsmasq.* | sort

If output from above one contains a line with an interface= directive, you can expect Pi-hole to not reply on all interfaces.

There is one.

That rogue 02-addint.conf file is probably the cause.
Move it out of there to your home folder for backup/reference:

sudo mv /etc/dnsmasq.d/02-addint.conf ~

And restart the daemon:

sudo service pihole-FTL restart

Yes! That did it!

Any ideas as to what could have caused this?

Wrong or incomplete VPN howto’s.
What guide did you follow to setup VPN ?