PiHole DNS and FTL not running


Actual Behaviour:

DNS and FTL status change to not running in every 8 to 24 hours. Need a reboot to fix.

Debug Token:

[✓] Your debug token is: lu5zan0zwi

Running on google cloud debian9 and same experience with others server hosted on Azure. Is this normal?


This is not normal. One thing appears in your debug log that may be a contributor:

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface: does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

Pi-Hole is setup to listen on this IP: IPV4_ADDRESS=xx.xxx.2.73. When I run a dig to this IP, I receive a valid IP in return.

I deleted the first two strings in the IP address because you are running an open resolver, which is very bad practice. You should close this open resolver.



We’re testing a fix for some issues in v4.2.1, it would be helpful to know if this branch fixes your issues:

pihole checkout ftl tweak/overhaul_overTime


ok, testing it now. I will update here.


Fixed my problem :slight_smile:


Thats what i got on this xx.xxx.2.73. How they got my ip? Server was running from about 15 days.
And another server same issue, with in 24 hours of pihole -d command.


The number of IPv4 addresses is countable. It may be less than you think and already too few for all Internet capable devices worldwide. Because there are fewer than 4.3 addresses available, depletion has been anticipated since the late 1980s, when the Internet started to experience dramatic growth. There are services out there that scan the entire Internet in a day (or even less), quickly discovering any new machines.

Please note: Security by obfuscation is not only a bad idea, but has been proven repeatedly to not work at all with IPv4 addresses.


So i can’t user public ip as dns server like cloud flare Only option is vpn or local pihole?


The answer to this would be yes.