Pihole DHCP not working - bullseye raspberry pi

Your debug token is: https://tricorder.pi-hole.net/K6isvhmx/

long story short:

pihole dhcp on bullseye does not seem to be working for network devices.

my main pihole (dns + dhcp) seems to have died on me, however i have semi recent backups of most of the files; iptables, network, and pihole. i have a spare pi that i upgraded to bullseye, and using the backup files mostly have a running pihole again. when i access the pihle gui/settings, seems to have the necessary configs, and the static leases, and the "dhcp server enabled" checked. however, devices do not seem to be able to get any leases. iptables should be configured exactly to how the main server was, allowing dhcp 67/68. dns is working fine for devices, when pointed to this pihole (and manual static network settings)

Thanks, resolved. did not realize it reads ALL files in the "/etc/dnsmasq.d/" folder; which contained a backup from another system which indeed includes the no-dhcp. sorry, and thanks!

Your Pi-hole installation is a highly customised, heavily relying on individual dnsmasq configuration options.
One of those options is telling your Pi-hole not to supply DHCP via eth0:

*** [ DIAGNOSING ]: contents of /etc/dnsmasq.d
-rw-r--r-- 1 root root 505 Dec  7 00:28 /etc/dnsmasq.d/05-pihole-mycustom.conf.backup-2021-12-07-before-raspbian5


*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] spravajestjasnsa.club is on lo (
[✓] spravajestjasnsa.club is on eth0 (
[✗] Failed to resolve doubleclick.com via a remote, public DNS server (

As eth0 is the only available interface on your RPi, your custom config effectively disables Pi-hole's DHCP server.

It would also seem that your Pi-hole host isn't able to request DNS resolution through a public resolver. This may suggest outbound port 53/DNS being blocked, either on that host itself or on the router.

You may also want to revisit your configuration, as some of the options seem off, e.g. you have configured DHCP to distribute your Pi-hole host machine's IP as time server, but there is no process listening on port 123/NTP (and an RPi would make a suboptimal choice for a time server in general, for lack of a battery back-uped RTC).

When adjusting your custom configuration files, you may use the following command to verify whether your configuration is at least syntactically correct:

pihole-FTL dnsmasq-test

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.