Pihole blocks everything

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

[Block ads and just ads]

Actual Behaviour:

[Running on a pi zero w with ethernet connected and a static ip address assigned in the router. The pihole seems to not be able to resolve domains ie DNS isnt working. Pages wont load period.]

Debug Token:

Edit - moderator made debug log private

0 Likes

#6

You don’t have an IPv4 gateway listed, so there might be a gateway issue. What are the outputs of these commands from the Pi terminal:

ip -4 address

ip route get 8.8.8.8

0 Likes

#7
pi@raspberrypi:~ $ ip -4 address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    inet 192.168.2.178/24 brd 192.168.2.255 scope global eth0
       valid_lft forever preferred_lft forever

pi@raspberrypi:~ $ ip route get 8.8.8.8
RTNETLINK answers: Network is unreachable

pi@raspberrypi:~ $ curl https://google.com
curl: (6) Could not resolve host: google.com

Also, does it matter if I have IPv6 enabled? It said it was not available during install. Also also, I used ssh to get into the pi so that works.

0 Likes

#9

What is the routing table for IPv4: ip -4 route ?

0 Likes

#10
pi@raspberrypi:~ $ ip -4 route
192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.178 metric 203
0 Likes

#11

For some reason you do not have a default route or a gateway for IPv4 to access anything other than your local network. Notice below there is a default path for any non-local traffic to take. How are you setting the IP address on your Pi?

$ ip -4 route
default via 192.168.100.1 dev eth0 proto static metric 100 
169.254.0.0/16 dev eth0 scope link metric 1000 
192.168.100.0/24 dev eth0 proto kernel scope link src 192.168.100.2 metric 100
0 Likes

#12

SOLVED
I had told the internet configuration that I wanted to manually set connections (gateway, route, ect), I input my static Ipv4 ip and forgot to set the rest. Pihole is working now.

Dumb related question: Do I need an ipv6 address?

0 Likes

#13

Only if you are using IPv6. If everything works for you without and IPv6 address, then you do not need one.

0 Likes

closed #14

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes