PiHole and Google Fiber Router not working for all devices

Ok, I have scoured the forums and have found similar topics in regards to this situation and router but it seems that before a solution is ever found, that topic/thread gets automatically closed. I am attempting to find an actual solution and keep this thread active until a solution is found.

Here's the current setup: I have a Raspberry Pi 4 B 8GB with PiHole running on it (I know, overkill but this is what I had on-hand) directly connected to my Google Fiber router (with a 2.5Gbps plan and there doesn't seem to be a lot of other router options that can properly handle that amount of throughput).

My PC's, TV, etc., for the most part, seem to be working just fine. About 96% of all ads are blocked on ad-blocking test sites (like: Test Ad Block - Toolz) Except... Our android phones are NOT blocking ads when connected to the Google Fiber Router. We have disabled Private DNS on the android devices and have even tried setting static IP's and manually setting the IP address of the PiHole in the android phone but to no avail.

I believe (based on other, similar topics) that the problem stems from this routers inability to disable or even edit IPV6. It doesn't even show any information at all in regards to IPV6 but I know it's being used because when I disable it on Wi-Fi-connected PC's, I get ads blocked. Enable it and ads come through. And unfortunately we are unable to disable IPV6 on our android devices since AT&T locks that. It could be something else but I believe this is the issue as everything on IPV4 works perfectly and blocks all the ads.

It may be worth noting that this is only happening on Wifi and not ethernet/lan-connected devices.

I have also kind of confirmed this theory by plugging in another router (ASUS GT-AXE11000 which has IPV6 disabled) into the network, connected to that router on the Android devices and all ads are blocked. I would just go this route but for some reason, when connected to this router, the upload speeds are just fine (hovering at around 600-800Mbps) but the download speeds are almost nonexistent at a mere 5-10Mbps... I have no idea why. It was working fine on an XFinity/Comcast network but has extremely slow download speeds when connected to this Google Fiber router (connected with a short CAT8 cable but I also tried Cat6 and Cat7 just to see - same result).

Anyway, what I am really trying to find out is if anyone has been able to resolve this issue with the Google Fiber router (which btw, has the most limited user control I've ever seen on a router). Or can it be done through some PiHole settings? I don't think that it can be done through the PiHole but then, I am very new to this.

If the only alternative is to replace the Google Fiber router (which I believe uses an SPF+ connection to the modem), what is the best option that can handle up to 5Gbps (sometimes, during heavy workloads, we bump our service up to 5Gbps... it's awesome. but I haven't been able to find another, 3rd-party router that supports those speeds).

Any advice or solution to this problem would be greatly appreciated. Currently our Android phones get no ads blocked and it's very annoying to say the least.

I encountered another problem with some Android phones here, where they silently add Google's DNS server, causing some or even all queries to bypass Pi-hole. It may or may not be related to your situation, especially since you've tested further with the ASUS, but I thought worth mentioning as a data point, since it can be another cause of some Android phones bypassing Pi-hole.

Thanks for the reply.

Reading over this post: Yes, I believe I had already found the same thing and worked my way around it so I knew that wasn't the problem. Actually I believe I had already read parts of this same thread that you shared.

I messed around on my ASUS router and at least got it to where it's working ok. Definitely not running at the speeds I would like (it's running at around 200Mbps down and up instead of around 600 (which is what I used to get from this router on the other network) but 200Mbps still works and it is blocking 96% of all ads on all devices connected to the ASUS router. And again, the reason it's working there is because I have IPV6 completely disabled on this ASUS router, which forces all traffic through IPV4 which routs through the PiHole. When I enable IPV6 on the ASUS router, the Android phones again go with IPV5 and bypass the PiHole. So I do believe it's the IPV6 issue.

I should also mention that I did setup PiHole as the DHCP distributor but again, the IPV6 settings on the router were just bypassing that. It worked as expected for IPV4.

Now I'm trying to figure out how to get IPV6 setup on this ASUS router to where it directs all traffic to the PiHole - so that I can re-enable IPV6. As I said, I'm new to this so I'm reading through documentation, forums, etc. to see how to properly set that up.

When I connect a mobile device through the Google Fiber router, it always directs through IPV6 which has it's own, un-editable address that bypasses the PiHole. I contacted Google about it and they told me that there is no way to edit IPV6 settings on their router and that it is permentantly on and addresses locked.

So with that, I do believe that - if there is no way to resolve this through the PiHole or mobile devices (which, from everything I've been reading all day, seems to be the case) - the only real solution is to replace the Google Fiber router. It is a shame, because mine came with several Mesh devices that extend the network and now, if I want to do the same with my won routers, I'm going to have to purchase a several-hundred dollar router and mesh system of my own. It's very unfortunate that Google locks their routers down like this. I've never seen this level of restrictions on any router before.

I will, however, keep searching for another solution to get this to work with the Google Fiber Router. I figure that I will spend the next couple/few days on it. If I don't respond here with a solution, you can assume that I didn't find one. If anyone else has found the solution, I would love to hear it!

If you can find a suitable router that has the bandwidth capabilities, you may be able to put the Google router into bridge mode and connect your own router to it, relegating the Google router to acting as a fiber modem with the same connectivity, and moving all the networking elements to your own router.

I can't think of any way to fix it other than from the Google router. If it is advertising its own IPv6 networking and you have no control over it, and no way to avoid IPv6 on a client device, that device will use the router and not be using Pi-hole.

Since it's an Android device causing the problem, perhaps there is an app or hack that can reach in under the hood and disable the IPv6. Or maybe you can ceate an IPv4-only VPN to the house, even for when you're in the house, which might seem silly but perhaps can act as an IPv6 block of sorts.

Yep, I already tried bridge mode with the ASUS router to see if it would boost the Wi-Fi speed of the ASUS router a bit but unfortunately it didn't. Currently I have devices like light bulbs, light switches, Google Speakers and PC's (with IPV6 disabled) connected to the Google Fiber router and all other wireless devices (smartphones, tablets, etc.) connected to the ASUS Wi-Fi (where IPV6 is disabled in the router settings).

It's working ok for now, still not exactly ideal but I'm still looking into other solutions. I wish there was a way to root the Google Fiber router. It seems like a great, reliable, fast router but it's just lacking editability in the settings.

I also know that I can root the Android devices to take full control of all of the settings but I really just want to make it all controlled on the network side - so that even guests can enjoy an ad-free experience. There may also be an app for that but again, I'd rather find a network solution if possible... I will take a look at available apps though, just to see. Thanks for the advice.

Anyway my current mission is to find the best router that can handle high-throughput and has mesh network capabilities. Seems like there are several options available, just narrowing it down to figure out which one would be best for me.

This ASUS GT-AXE11000 should be good enough for this but I'm not sure why it's having issues with speeds. I get 850mbps down and up on my Android when connected to Google Fiber router but only around 200Mbps on the ASUS. It's odd. And that ASUS is connected to the 10g output of the Google Fiber router and using the 2.5G input of the ASUS router. I tested that line on a PC and it got around 2,300Mbps down and up (which is the limitation of the ethernet port on the PC). So that amount is being sent to the ASUS but it's just not outputting the expected ~1G bandwidth on the Wifi to a Wi-Fi6-enabled smartphone. I can't seem to figure that part out. I also still had my comcast modem/router here and service was still active so I plugged the ASUS router into that and it output closer to 800Mbps download (which is also what I got on ethernet for that Comcast connection). So it's definitely capable, just not working properly when it's connected to the Google Fiber connection. I know that this is kind of a separate subject/off-topic for this Pi-Hole forum but I'll still try to provide information here if I find a solution for that. It is, after all, in an effort to get network traffic to route through the PiHole.

Update: As of 11/29/2023 and after nonstop research and tests, I have concluded that at this time, there is no way around this other than to purchase a separate router and use that. I managed to get my ASUS GT-AXE11000 to provide the correct throughput (up to around 700-800 mbps download and upload over Wifi 6 connection) by installing a 3rd party firmware (Asuswrt-Merlin) - simply installing that fixed it. Updating via ASUS official firmware did not fix it.

I can only hope that Google will eventually update their router firmware to allow more user control but knowing Google... I highly doubt they will do that. Perhaps someone will create a third-party firmware (like they have done for ASUS) that unlocks these features but until then... yeah, the only solution seems to be to get a different router to connect to the network and route all wireless devices through that.

Anyway, I hope this is helpful to someone else out there. I definitely still recommend doing research on it because who knows, maybe I missed something or maybe there will be a better solution sometime in the future but as of right now, this is all I have found.

1 Like