Pi Server port change issue

The issue I am facing:
Been trying to change the server port for Pi-hole from default 80 as will be deploying Open Media Vault on the same device. Was able to change "server-port" from 80 to user-defined one in lighttpd.conf file but as many have said that this isn't a permanent solution as Pi-hole would revert to 80 upon next update.

Solution was said to be making similar entry in external.conf BUT that is an empty file and when I do make a such an entry into it and then try to restart lighttpd service I get the error:-
"Job for lighttpd.service failed because the control process exited with error code. See "systemctl status lighttpd.service" and "journalctl -xe" for details."

Been referring to this link for it; https://raspberrypi.stackexchange.com/questions/52090/how-do-i-change-pi-holes-url-path
Details about my system:
Raspberry Pi 4 4GB variant, connected to an ONT via Ethernet cable and Router's DHCP configuration has Pi's Ethernet interface IP as DNS
What I have changed since installing Pi-hole:
Nothing, except the server port in lighttpd.conf file

You're out of luck here:
While Pi-hole won't touch external.conf, settings in there are not allowed to conflict with PI-hole's own settings, i.e. you cannot reassign its port.

You'd have to stick with changing lightttpd.conf and rememberiing to edit it again after updates.

Alternatively, you may try to configure OVM's webserver to host Pi-hole's UI as well.

Pi-hole's support is limited to lighttpd, but you may find a user who has solved that problem for OMV.

To increase your chances to attract such users, try to put OMV in your topic's title. :wink: