Pi-hole works well on device level but not when set on the router

The issue I am facing: I can manually configure my devices to use Pi-hole as DNS server (on iPhone, WIndows laptop, Linux laptop etc.). And all works well. But when I set my router DNS to be Pi-hole DNS, nothing works any more. I can change router DNS to be e.g. or and all works well. I can also test that DNS really changes when I change router settings.

Details about my system: Pi-hole is on Raspberry Pi 3 which is on local network. My router is Nokia Beacon

What I have changed since installing Pi-hole: Nothing

Is this a new router / new setup? Has it worked before but just stopped?

I recall issues with some routers will not allow a local DNS Server Address for security sake. I can't for the life of me remember the specific term. I seem to recall in those cases the router would not even take the local IP in the setting.

I would suggest posting the results of a dig / nslookup from a client with both the piholle set as DNS in the router and with or

You may also want to upload a debug file ( tool>generate debug log ) and post the link. A developer or moderator will like want to look at it.

Thx for help.

Router and local network is "old", but Raspberry Pi with Pi-hole is newly added.

After some tests made, I found the "solution". So, I will leave it here if anyone has same problem.

I need to switch off Pi-hole, set router DNS as “non Pi-hole DNS” e.g. and restart router (off/on). All works well, but of course without Pi-hole. Then I switch on Pi-hole and set router DNS to be Pi-hole DNS. Ta-da... All works well, with Pi-hole.

If now I switch off/on Pi-hole, it will work well again. But if I switch off/on router with Pi-hole set as DNS, system will not work, network devices cannot go to internet as DNS cannot find web sited addresses.

For me this solves the issue, so I will not investigate more, for now…

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.