Pi-Hole works everywhere except Android Phones


#1

I recently set up Pi-hole on my home network. I am using the Pi-hole as the DHCP, and it is successfully blocking ads on my computer. However, my Android phone completely ignores the Pi-hole DNS despite Network Info II reporting that it is my only DNS server. I’ve looked through other people’s help posts, but none of their solutions have fixed my problem. Does Android use different DNS servers than it displays?


#2

Also have the exact same problem and am yet to find a solution


#3

Is it not blocking ads in every app, and which specifically? It’s working fine on my devices.


#4

It blocks zero adverts on my device.

Both in chrome, stock Samsung browser and in app ads

I’m running in a Galaxy S6, android 6.0.1

I’ve tried setting DNS manually and it makes no difference


#5

Can you reach http://pi.hole/admin?


#6

No, the Android devices fail to reach http://pi.hole/admin


#7

Also the same, get a DNS error.

I have to reach the admin page via http://ip_addr/admin


#8

Have you tried restarting the device? What Android devices are having the issues?


#9

I have restarted the device as well as cleared Chrome’s DNS cache.
I’m using a Samsung Galaxy S7 with Android 7.0


#10

I too have restarted the device, flushed DNS cache via chrome flags and cleared chrome app cache


#11

On Android, you can check DNS servers assigned with:

getprop net.dns1
getprop net.dns2

But need terminal/console for that.

Ps. pi.hole/admin works fine on my stock Nexus 7.


#12

Hmm interesting, when I run

getprop net.dns1

It returns an IPV6 address

getprop net.dns2

Returns my pihole address in ipv4 format.

The dns1 address is not the IPV6 address of my pi.


#13

Both of those return IPv6 DNS servers set by my ISP in my router. There doesn’t seem to be a way to change these in my router’s settings. Does this mean Pi-hole will never work on my Android device?


#14

It also seems strange to me that my Android device is getting its IPv6 DNS from the router, while my computer is correctly setting its IPv6 to the Pi-Hole’s IP


#15

You said you were using Pi-hole for DHCP? Did you make sure to turn off the router’s DHCP? Do you have IPv6 connectivity? If not, run pihole -r and set Pi-hole to only use IPv4.


#16

See the above comment.


#17

The router has the option to disable DHCP for IPv4, which I’ve done. For IPv6, the only options are “Use DHCP Server” or “Auto Config,” and neither of them has fixed my problem.
The IPv6 link you sent reported a 17/20, where the issues are “ICMP: Filtered” and "Hostname: None."
Should I try the Pi-hole with only IPv4?


#18

Yes, try only IPv4 on the Pi-hole.


#19

I use pihole as a dhcp server.
I have disabled it on my router.

According to IPV6 test I do have connectivity, yes.
Should I still reconfigure to use only ipv4?


#20

Run pihole -d for a debug token. It might be handing out the wrong IPv6 address.