Pi-Hole with Stubby - FTL not loading


#1

hi community.

I have stubby installed, unfortunately I have since then no FTL connection more. have the system completely reinstalled and as soon as I install stubby he loses the FTL connection. Can anyone explain to me? maybe something stuck with PiVPN? About help, Iā€™m grateful :slight_smile:


#2

This sounds like a stubby configuration problem. Please upload a debug log and paste the token here and we can look at the Pi-Hole side of the setup.


#3

https://pastebin.com/kjiGzmYC

the funny thing is that I can not update raspi via sudo apt-get update anymore.

thanks for the help =)


#4

This appears to be because your DNS resolution is not working on the Pi. From your debug log it appears stubby is on port 53, which is the port pihole-FTL needs.

*** [ DIAGNOSING ]: Ports in use
127.0.1.1:53 stubby (IPv4)
[::1]:53 stubby (IPv6)
*:22 sshd (IPv4)
*:22 sshd (IPv6)
*:80 lighttpd (IPv4)
*:80 lighttpd (IPv6)

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[āœ—] Failed to resolve ads.pointroll.com.29591.9190.302br.net via localhost (127.0.0.1)
[āœ—] Failed to resolve ads.pointroll.com.29591.9190.302br.net via Pi-hole (192.168.178.7)
[āœ“] doubleclick.com is 172.217.168.14 via a remote, public DNS server (8.8.8.8)

#5

thanks, I must open in the iptables port?


#6

No, I think you need to get stubby installed so it listens on a port other than 53.

Did your Pi-Hole work properly before you installed stubby?


#7

the PI hole worked perfectly before, only when I stubby installed comes the ftl is offline.

Unfortunately, do not continue :frowning:


#8

Your solution would be to uninstall stubby, then install stubby correctly.

Another encrypted DNS option is DNS over HTTPS.

https://docs.pi-hole.net/guides/dns-over-https/


#9

Thank you, I will rebuild the system and try unbound. would not know what I did wrong with stubby.