Pi-Hole VLAN interfaces partially running

### My Pi-Hole has a standard setup
Hardware: Raspberry Pi 3+
OS: Raspbian

## Expected Behaviour:
ALL interfaces configured in Pi-Hole should be able to ping & route to its gateway IP address (SVI), but two interfaces cannot ping or route.

## Actual Behaviour:

See attachment for illustration of how my network is setup.

Just after installing Raspbian on my Pi device, I checked to ensure all its respective VLAN gateway (SVI) were pingable to/from Pi-Hole and to/from the L3 switch...ok.

Once Pi-Hole was installed, I began to configure the ad-blocking service for DNS, DHCP and the interfaces for each of the VLAN it will serve.

Files I modified through SSH:

  • /etc/dnsmasq.d/10-additional-dhcp.conf for my VLAN scopes
  • /etc/network/interfaces - DNS for each VLAN
    • VLAN 10 - 10.0.10.253 (IoT)
    • VLAN 20 - 10.0.20.253 (Guest)
    • VLAN 30 - 10.0.30.253 (Home)
    • VLAN 192 - 192.168.1.253 (Mgmt, Primary (eth0))

Example of /etc/network/interfaces
auto eth0
iface eth0 inet static
address 192.168.1.253/24
gateway 192.168.1.254

auto eth0.10
iface eth0.10 inet static
address 10.0.10.253/24

auto eth0.20
iface eth0.20 inet static
address 10.0.20.253/24

auto eth0.30
iface eth0.30 inet static
address 10.0.30.253/24

After adding the above configuration onto the "interfaces" file and rebooting, ONLY 192.168.1.253 & 10.0.30.253 was able to ping its gateway (x.x.x.254) and vice versa. The other two interfaces are not able to ping its router (x.x.x.254).

Interface listening behavior is set to "Listen on all interfaces"

Ad-blocking is operational for VLAN 192 & 30.

Debug Token:

0vroajuof7

Thank you.!

home-nw|690x276

This would be a basic networking issue, and most likely, you'd have to deal with this at your router/switch, as that should take care of inter-VLAN routing.

Depending on how that's done, it might not be necessary to define additional virtual interfaces on your Pi-hole machine at all - have a look at how slowlearner succeeded setting up multiple VLANs in Extra DHCP Server Options.

(As a side note: Starting with Raspbian Jessie, network configuration has shifted from /network/interfaces to /etc/dhcpcd.conf. While definitions in the former still work, you probably should verify that the latter doesn't interfere or contradict with them. Ignore me if you're already aware of this.)

I thought it was something on my switch too, but the moment I remove ALL interface extensions on the Pi-Hole the SVIs on the L3 switch are then reachable.

I'll test with etc/dhcpd.conf .