Pi-hole v3.3 Released: It's "Extra" Special

release-notes
v3-3

#12

Just waiting for @DanSchaper announcement as he said to do a manually upgrade to official release with the fix.
At the moment i’m staying in Dev (HEAD, v3.2.1-0-ge602008)


#13

I expect we will have instructions when the bugfix release is out. However, running pihole checkout master will allow you to update (and if you already tried updating to 3.3, this will checkout out 3.3).


split this topic #14

A post was split to a new topic: Unable to update web interface v3.3


#15

Just FYI: Raspbian Jessie user on Pihole 3.2. I waited with updating and just came back to check status on how to move to 3.3. Read the post on how to update dnsmasq. Started by trying “dnsmasq -v” to see which version I have now, so I can later validate updating it to 2.76 but to my surprise it is already reported as being 2.76. And I surely haven’t done any of the steps in that guide.


#16

I am having dnsmasq-troubles on my Synology DS-413j, which is obviously running a Jessie-Debian on “armel-architecture”.

Consequently this will fail to install.
I’m a completely ignorant Linux-Dummie and have not the slightest grasp of what I’m doing here.
I have google for dnsmasq-base 2.76-5 and armel, but have not found anything.

On
https://archive.raspberrypi.org/debian/pool/main/d/dnsmasq/
there is no arm-thingy of any sort except the “armhf”, which is not compatible.

Somwhow I have managed to remove dnsmasq completey and can’t find a way to install it again.

curl -L https://install.pi-hole.net | bash

is not installing it, either.

Any hint on how to get basic functionality of pihole again until your new version with ftldns will be final?


#17

Unless you can find at least version 2.73 of dnsmasq for Debian Jessie, you should update to Debian Stretch or downgrade to Pi-hole 3.2.1


[PSA] Bugfix release 3.3.1 for Pi-hole Core [Read before running pihole -up]
#18

Thanks a lot, it was a headache why pi-hole not working with OMV.


#19

Hello,
It’s been some time being on 3.2.1 and I cannot update any further on the RiPi 3. Is pihole done for RiPi 3 now or still working on a proper fix where everything runs and install successfully


#20

We are working on 4.0 and have had that in beta for a bit. The 4.0 release will fix the inconsistencies with dnsmasq. I’m not sure why you are having problems with the RPI 3 as the problem is with Raspbian Jessie, with Raspbian Stretch you can run 3.3 on the RPi 3?


#21

I can leave it be for now, I have ran this for months like this
Pi-hole Version vDev (HEAD, v3.2.1-0-ge602008)
Web Interface Version vDev (HEAD, v3.2.1-0-g31dddd8)
FTL Version vDev (v2.13.2 , v2.13.2 )

I have tried to run a fresh install (clean SD) and seems to still have concerns. That sounds promising about 4.0! I look forward for any future updates to get this back in action. I love pi-Hole!
Keep me posted
Thanks for the quick response


#22

Hello,
How’s 4.0 looking ?


#23

It’s in beta testing now, finishing up some odds and ends but no timeline for it’s release. You can join the beta along with the other users that are helping us get it out.


#24

Noticed i had whitelisting issues, seems if you try a few times it some times sticks. Should have just stayed on 3.2.1 until 4.0


#25

I could do that. I haven’t touched or updated Pi-Hole because of all the issues.
How can I help, I can’t even update my current version anymore, I have to make a new SD


#26

Here are the command lines if you would like to try it. I’ve been using it for a week or so now, very nice web interface, under the hood improvements, etc.

echo release/v4.0 | sudo tee /etc/pihole/ftlbranch 
pihole checkout core release/v4.0 
pihole checkout web release/v4.0

#27

Thank you!
I am sure I have an SD card around somewhere else to swap out. I will add this to my weekend to-do-list. Working on some other things over the week.

If I am formatting a fresh SD, I will have to read the instruction set to see how to install again, it’s been a while (basic unix user here)


#28

If you are starting from scratch, after you install your OS, run the Pi-Hole install curl command to get Pi-Hole on your device, then run the branch checkout commands listed above.

curl -sSL https://install.pi-hole.net | bash


#29

Thanks man


#30

I haven’t got on the BETA for 4.0 yet. How is 4.0 looking?


#31

The beta is gone and 4.0 is looking good. There must be a blue area on top of your screen stating that or did you close that without reading it?