Pi-Hole test page unblocked


#1

Expected Behaviour:

When going to the pi-hole test page, ads should be blocked.

Actual Behaviour:

Ads are not blocked. Block Ads! tells me that I have no ad blocker running, and all of the banner ads on the page are shown.

Debug Token:

c8q7qd2zip

Other information:

My gateway is an ActionTec T3200M provided by Telus. I’ve gone into the LAN IP Settings, chosen static IPs for the DNS servers, and set the first DNS server to 192.168.1.55 (my Pi-Hole’s static IP) and left the second one blank. When I run ipconfig /all on my main PC, I get:

DNS Servers . . . . . . . . . . . : 2001:568:ff09:10a::55
2001:568:ff09:10b::122
192.168.1.55

I haven’t tried setting the pi-hole as the DHCP server yet mainly because I can’t figure out how to disable it on the gateway.

Thanks for any help.


#2

Most likely you are getting ads via the IPv6 address and the IPv6 DNS servers. If http://ipv6-test.com/ shows that your clients have IPv6 addresses, then you will need to set the Pi-hole up for v6 or disable v6 on the network.


#3

The page shows that IPv6 connectivity is supported and the IPv6 address they list matches the one I get from ipconfig /all. I enabled the IPv6 DNS server on my pi-hole, just need to find the IPv6 settings on my gateway now.


#4

You may be able to just set an IPv6 DNS address in the same space as the IPv4, some routers will allow that. And in case your ISP rotates v6 address, check and see if you can assign ULA addresses (addressing similar to the internal 192.168 address scheme but for IPv6.) Using ULA tends to be more stable as far as long term use. If you can figure out how to use Pi-hole as the DHCP server then a lot of the configuration becomes easier to do.


#5

Looks like the IPv4 DNS server address field only supports up to 16 characters, so it must be elsewhere here. It sounds like the only way to disable DHCP on the gateway is to put it into bridge mode and I’m concerned that it will break all of the set top boxes here, so I think the best bet is to change the IPv6 DNS for now.


#6

So as a test, I disabled IPv6 entirely on of my PCs so the only DNS server listed is the IPv4 address and everything is blocked now. I’ll figure out how to block everything on IPv6 from the gateway side now.


#7

For now, I’ve disabled the IPv6 settings on my gateway, and that works.

I also use OpenVPN and that was causing issues, but I’ve resolved that by changing the OpenVPN network adapter’s settings to use my pi-hole rather than my VPN’s DNS servers


#8

Good, IPv6 can be a bit of a tricky situation to configure, might be good to just disable it for now until you’re sure things are working well and then re-enable some time when you have the chance to work it through.