Pi-hole Suddenly Not Resolving DNS Query

Please follow the below template, it will help us to help you!

Expected Behaviour:

My Pi should be resolving DNS queries, but it is not. I am using the latest Pi build.

Pi-hole v5.5 FTL v5.10.2 Web Interface v5.7 on a Pi 1B hardware on Raspberry Pi OS.

Actual Behaviour:

Pi-hole is not resolving any DNS queries even though my router had pointed the DNS to the pihole (192.168.1.150). I have already tried DNS flushing the pi, rebooting the Pi, and running 'pihole -r'.

Debug Token:

I couldn't upload the log to server, so I have uploaded it here instead.
pihole_debug.zip (11.4 KB)

Maybe your router does not accept the setting. Looking at your debug log, it looks like no DNS queries are sent to the Pi-hole. It works correctly but only handled queries from the local machine (because it does not receive any other)

At the time of creating this post, when I ran the debug command, the DNS setting of my router was set to use Cloudflare DNS (since my internet would not work if I used the pihole).

Should I set the DNS to use pihole on my router and re-run the debug command?

EDIT: I have just re-run 'pi-hole -d' with pihole enabled. It cannot upload the log to your server.

[✗] There was an error uploading your debug log.

  • Please try again or contact the Pi-hole team for assistance.
  • A local copy of the debug log can be found at: /var/log/pihole_debug.log

pi@raspberrypi:~ $

What should I do?

EDIT2: I couldn't upload the log to the server while using pihole as DNS, so I retrieved the local copy.

pihole_debug.zip (11.4 KB)

Anyone else?

Sorry for the delay, your Pi-hole still seems to be receiving almost no queries. However, I've seen one correctly handled query from 10.6.0.1 which seems to be your Wireguard interface wg0. Other tests have shown that Pi-hole is listening and handling queries received also on the eth0 interface.

However, another test failed to reach the public DNS server 8.8.8.8:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] smtp.eastfarmingdale.bluehornet.com is 0.0.0.0 on lo (127.0.0.1)
[✓] smtp.eastfarmingdale.bluehornet.com is 0.0.0.0 on eth0 (192.168.1.150)
[✓] smtp.eastfarmingdale.bluehornet.com is 0.0.0.0 on wg0 (10.6.0.1)
[✗] Failed to resolve doubleclick.com via a remote, public DNS server (8.8.8.8)

Do you have, by any change, set up a firewall that may be blocking things here?

The only firewalls that I have set up are the default Windows Firewall on my desktop PC, and the default firewall from my router.

Should I disable the firewall on my router and see if it works?

EDIT: I disabled the router's firewall, but pihole still wasn't working.