Pi-hole slow to load certain sites

fritzbox

#1

Hi,

Pi-hole:

DNS:

IPv4:

IPv6:

Router always assign ULA:

iptables -nvL

ip6tables -nvL

Example ad blocked in 4.29s
https://www.google-analytics.com/analytics.js


#2

also running pihole -r
gives me the following output i think something wrong with FTL sometimes ads are blocked and sometimes they arent

i ve reinstalled it now it tells me that ftl is running but still ~4s


#3

What is the output of :
sudo systemctl status dnsmasq
sudo systemctl status pihole-FTL

And what operating system are you running Pi-hole on ?

Have you seen this post:

There might be some answers there.

You might want to upload a debug log for the developers to look into any possible errors (pihole -g)


#4


Raspberry Pi Zero

RASPBIAN STRETCH LITE
Minimal image based on Debian Stretch
Version: April 2018
Release date: 2018-04-18
Kernel version: 4.14

Yes i’ve seen the post but i think it didnt helped maybe i missed something or doing wrong i dont know


#5

Someone with a Fritzbox fixed with this:


#6

I dont want to insert the IP Address of my Pi in the router because i dont want to use the adblocker globally.

But there is a IPv6 Tab

whats the difference between Native IPv4-Connection and Native IPv6-Connection in the IPv6-Connection fieldset?

IPv4-Connection is recommended and selected as default:

I’ve just selected IPv6-Connection to show the hidden options:

Some other IPv6 configuration options (i’ve enabled ULA):

Default settings:

I’ve just selected disable DHCPv6-Server to show the hidden options:


#7

here the debug token: ns1nwpysog
today the request was blocked in ~2.15s
not sure why it takes up to ~4s and today its half of the time.


#8

You could disable IPV6 for your internal LAN. As in disable IPV6 on your fritzbox as well as on your Pi.

I think some requests from clients try to resolve via IPV6 and since that is not defined in Fritzbox, it takes a little bit of time, for the request via IPV6 to time-out and fall back to IPV4.


#9

Hmm i can disable it but what do you mean with my IPv6 is not defined?
My FRITZ!Box is telling me that my pi got an IPv6 address and i ve also set the dns server manually on my client to my pi holes IPv6 address so it should use the pi holes dns server.

Cable modem

Raspberry Pi Zero (Pi-Hole)

So you mean using both options (IPv4 and IPv6) may lead to a longer request time because of the time-out (fallback). Running only one option (IPv4 only) should avoid the fallback.