Pi-Hole Server A record responds to

I just finished deploying Docker container to RPi4 for the first time. I am noticing that when I ping my Pi-Hole server that the response is When I run dig on the FQDN the A record responds as

[ed@edfed: ~]$ ping pial
PING pial.offworld.lan ( 56(84) bytes of data.
64 bytes from localhost ( icmp_seq=1 ttl=64 time=0.016 ms
64 bytes from localhost ( icmp_seq=2 ttl=64 time=0.020 ms
64 bytes from localhost ( icmp_seq=3 ttl=64 time=0.027 ms
--- pial.offworld.lan ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2037ms
rtt min/avg/max/mdev = 0.016/0.021/0.027/0.004 ms

[ed@edfed: ~]$ ping pial.offworld.lan
PING pial.offworld.lan ( 56(84) bytes of data.
64 bytes from localhost ( icmp_seq=1 ttl=64 time=0.013 ms
64 bytes from localhost ( icmp_seq=2 ttl=64 time=0.024 ms
--- pial.offworld.lan ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1057ms
rtt min/avg/max/mdev = 0.013/0.018/0.024/0.005 ms
dig pial.offworld.lan

; <<>> DiG 9.16.24-RH <<>> pial.offworld.lan
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55341
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;pial.offworld.lan.             IN      A

pial.offworld.lan.      0       IN      A

;; Query time: 0 msec
;; WHEN: Thu Mar 10 09:53:16 EST 2022
;; MSG SIZE  rcvd: 62

I had Pi-Hole running on the same server (running AlmaLinux 8) before from an install instead of deploying a Docker container. Because of reasons I had to completely reinstall AlmaLinux 8 on the RPi4 and decided to use a Docker container instead this time around. I am pretty sure that from the last build that pings to the hostname of the Pi-Hole server and dig responded with the actual server IP address.
What is different now and how do I fix it to no longer respond to the loopback address and

Here is my Docker compose file:

version: "3"

# More info at https://github.com/pi-hole/docker-pi-hole/ and https://docs.pi-hole.net/
    container_name: pihole
    image: pihole/pihole:latest
    hostname: pial.offworld.lan
      - "53:53/tcp"
      - "53:53/udp"
      - "67:67/udp"
      - "80:80/tcp"
      TZ: 'America/New_York'
    # Volumes store your data between container upgrades
            - '/mnt/docker/etc-pihole:/etc/pihole/:z'
            - '/mnt/docker/etc-dnsmasq.d:/etc/dnsmasq.d/:z'
    restart: unless-stopped

This is a consistent behavior on all clients on the LAN.
Thanks for your assistance.

Actually, I think I fixed it. I added the following to the Docker compose file:


I hope that is a good practice?

That is a known issue and setting FTLCONF_REPLY_ADDR4 the recommended way to go. Citing from another post:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.