Pi Hole routing traffic with "lan" suffix

The issue I am facing:

DNS resolving issue. Error with DNS .Very slow internet through pihole.
Though speed test showing correct speed. But the routing logic breaks somewhere and create a loop which takes a long time before it routes the traffic to internet

Details about my system:

Pi zero set as DNS and DHCP server with a static IP
Motorola router configured to use the pi ip as the Primary DNS

Ubuntu

log file: https://tricorder.pi-hole.net/tgp5ej37l4

What I have changed since installing Pi-hole:

Added some blocked domains

Pi-hole isn't a router, nor should you be routing your traffic through a Raspberry Pi.

Not sure what gave you the impression that I am using pihole as a router. I specifically mentioned abiut DNS and DHCP which was the working solution provided by many. I was using cloudflare dns in the dns settings tab. The DNS errors are very very frequent and not resolving the names of common servers. Retrying multiple time works. Not sure if Pihole is good enough to work as a DNS for long enough or it has some limitations in terms of resources

The subject of the topic is "Pi Hole routing traffic with "lan" suffix".

So when I type an address until the response comes back to me-- everything in between is routing logic for me. That includes the DNS.

Can you please solve the issue by looking at the debug log?

Your debug log is normal.

Why and where is the router configured to use the Pi as Primary DNS? You have Pi-hole configured as DNS, so the router should have no involvement in assigning DNS servers.

What evidence do you have that this is the case? Some output from your logs would be helpful - in particular from /var/log/pihole.log

"Pi Hole routing traffic with “lan” suffix"

Pi-hole will route any traffic that it receives per your settings. Is google.com.lan resolvable on your network? You have selected the following two options (shown in your debug log as follows) and this tells Pi-hole not to forward those queries to the internet for resolution. The domains don't exist on your LAN either, thus the NXDOMAIN reply.

*** [ DIAGNOSING ]: Setup variables
    ...
    PIHOLE_DOMAIN=lan
    ... 
    DNS_FQDN_REQUIRED=true
    DNS_BOGUS_PRIV=true

What client is making the request for the domain google.com.lan? That's where the problem lies.

Maybe it is Windows. When the upstream is slow, it will try again the same domain with the network TLD attached.

I have reloaded everything from the scratch. Things are looking better now. The client is running on pop os (ubuntu) linux distro.