Pi-hole + RaspAp - devices connected to AP should NOT use pihole-DNS

I am using an Rapsberry PI 3 B+. I installed RaspAp. Then i installed pihole. Then i did

sudo touch /var/lib/misc/dnsmasq.leases
sudo chown pihole:pihole /var/lib/misc/dnsmasq.lea
sudo reboot

found here discourse.pi-hole.net/t/ftl-is-...

And it works. That is, all devices in my regular network (not using the raspap access point) use pihole as DNS server, and all ads get blocked. RaspAp works too. I can connect to the wireless lan it spans. But when connected to RasAp's wifi, my devices use pihole as DNS server too.

But i want AP devices not to use pihole as DNS server; i want to see ads there.

Tinkering with RaspAp's DNS settings in it's gui results in messing up pihole (FTL), so that i have to reinstall pihole to make things work again.

Do you have ideas/instructions for me? Thanks in advance!

Debug Token:


You can make a new management group in Pi-hole with no blocking applied and put these clients in that group.

I created a new group that i put my device into. I then added


as "Regex whitelist" entry. Which is putting in an * (asterisk) in the "Domain"-input-field while enabling the "Add domain as wildcard" checkbox. And then assigned that entry to the former new group. Works like a charme.

Thank you

Still, i'd be interested how one could circumvent wlan0 using pihole in the first place. Since there is only my router that instructs all my devices to use pihole's ip for dns resolving, i guess the devices on the raspap's wifi get their dns instructions from the router too. So my gut feeling is that it is due to raspap's dnsmasq being down and/or its settings being altered/destroyed by installing pihole after having installed raspap.

I just leave this subquestion open. Maybe over time someone posts a solution here.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.