PI-Hole only blocking 2% of the ads says UI

Hi all,

my PI-hole is only blocking 2% of the ads says the dashboard resp. 4% on Test Ad Block - Toolz.

Here is the log:

Could someone help me pls?

Best regards

The blocking rate is just a piece of informational data - by itself, it is not suitable to judge Pi-hole's operation, other than that Pi-hole is working.
It is also expected to fluctuate over time (sometimes wildly), depending on what domains your network tries to access, e.g. if your network would only ever visit discourse.pi-hole.net, blocking rate would be close to zero, and if you'd spend time mostly on Amazon instead, it would go up.

That said, your debug log suggests that your FritzBox router is advertising its own IPv6 as local DNS server:

-rw-r--r-- 1 root root 161 Feb  3 17:13 /etc/resolv.conf
   search fritz.box
   nameserver fd00:<redacted>8d
   nameserver 2a02:<redacted>8d

This allows your clients to by-pass Pi-hole.

You should configure your FritzBox to advertise your Pi-hole host machine's IPv6 as DNS server or to stop advertising its own, see e.g. Unresolved ipv6 adress in my top list - #4 by Bucking_Horn.

Hey Bucking_Horn,

thanks for the reply!

I tried doing whats posted in the link:
a. Untick Also announce DNSv6 server via router advertisement (RFC 5006).
b. Tick Disable DHCPv6 server in the FRITZ!Box for the home network and
b.1. choose There are no other DHCPv6 servers for the home network.

But that didnt work unfortunealty. Some of my clients werent able to connect to the internet afterwards.

So I tried this configure your FritzBox to advertise your Pi-hole host machine's IPv6 as DNS server"

(Thats the IPV6 of the pi-hole)

Do you mean like this? Sorry, I'm a bit of a noob.

The log now says:
-rw-r--r-- 1 root root 161 Feb 4 12:14 /etc/resolv.conf
nameserver fd00::52e6:36ff:fe02:828d <- who is that badboy
nameserver 2a02:8109:aa3d:1600:52e6:36ff:fe02:828d

Best regards

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.