Pi-Hole on Linux Mint 21.3

Hi. I have just installed Linux Mint 21.3 and I cannot intsal pi-hole on it. It shows that it's not supported with that OS.

I have checked below:
dig -t txt versions.pi-hole.net

; <<>> DiG 9.18.18-0ubuntu0.22.04.2-Ubuntu <<>> -t txt versions.pi-hole.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 573
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;versions.pi-hole.net. IN TXT

versions.pi-hole.net. 5 IN TXT "Raspbian=10,11,12 Ubuntu=20,22,23,24 Debian=10,11,12 Fedora=39,40 CentOS=8,9"

;; Query time: 55 msec
;; WHEN: Mon May 20 18:37:07 CEST 2024
;; MSG SIZE rcvd: 138

Have tried as follows:

curl -sSL https://install.pi-hole.net | sudo bash
curl -sSL https://install.pi-hole.net | PIHOLE_SKIP_OS_CHECK=true sudo bash
curl -sSL https://install.pi-hole.net | export PIHOLE_SKIP_OS_CHECK=true sudo bash

Any clue what else can I do?

Check this old post. It seems like there maybe some diffences in the curl command options


Just use a supported OS.


Your issue here is you are failing to pass the environment variable to sudo.

You have 2 options:

  1. use the -E option to allow sudo to preserve the existing environment:

    curl -sSL https://install.pi-hole.net | PIHOLE_SKIP_OS_CHECK=true sudo -E bash
  2. set the variable directly in the sudo command:

    curl -sSL https://install.pi-hole.net | sudo PIHOLE_SKIP_OS_CHECK=true bash


Linux Mint is not a supported OS.

It doesn't mean it won't work, but it means we never tested Pi-hole on this OS.
It also means we won't be able to verify and fix every issue if Pi-hole is installed on Linux mint.
You still can try to install Pi-hole setting the environment variable: PIHOLE_SKIP_OS_CHECK=true.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.