Pi-hole not working

Please follow the below template, it will help us to help you!

If you are Experiencing issues with a Pi-hole install that has non-standard elements (e.g you are using nginx instead of lighttpd, or there is some other aspect of your install that is customised) - please use the Community Help category.

Expected Behaviour:

pi-hole is supposed to use the adlists i import to block bad domains, and show what is being accessed/blocked via query log

Actual Behaviour:

very few local(?) domains only are being shown, setting dns to pi-hole on pc and phone yield no results image: https://i.imgur.com/cIZgLQO.png it also thinks there are 13 clients when there def arent
image

Debug Token:

https://tricorder.pi-hole.net/7Fgi9oLo/

i think the main reason for it being stupid is because i got a new ISP and they have ipv6, i've never had nor dealt with ipv6 so its a new thing for me, its also worth noting my ISP has 32 iq and doesnt allow me to edit DNS servers directly to the gateway, so i use my PC running pihole (10.0.0.72) as DNS server on the same pc, and my phone to get pi-hole to work, but it isnt working

In this forum, you can upload images directly and don't need to use links to imgur or others. This is preferred when you post images here.

A few notes from your debug log:

You aren't running our shipped code:

*** [ DIAGNOSING ]: Web version
[✓] Version: v5.20.1
[i] Remotes: origin	https://github.com/pi-hole/AdminLTE.git (fetch)
             origin	https://github.com/pi-hole/AdminLTE.git (push)
[i] Branch: master
[i] Commit: v5.20.1-0-g3a11976-dirty
[i] Status:  M settings.php
[i] Diff: diff --git a/settings.php b/settings.php
          index 6ad968d..b799c9f 100644
          --- a/settings.php
          +++ b/settings.php
          @@ -213,7 +213,7 @@ if (isset($_GET['tab']) && in_array($_GET['tab'], array('sysadmin', 'dns', 'piho
                               <a href="#dns" aria-controls="dns" aria-expanded="<?php echo $tab === 'dns' ? 'true' : 'false'; ?>" role="tab" data-toggle="tab">DNS</a>
                           </li>
                           <li role="presentation"<?php if ($tab === 'piholedhcp') { ?> class="active"<?php } ?>>
          -                    <a href="#piholedhcp" aria-controls="piholedhcp" aria-expanded="<?php echo $tab === 'piholedhcp' ? 'true' : 'false'; ?>" role="tab" data-toggle="tab">DHCP</a>
          +                    <!--a href="#piholedhcp" aria-controls="piholedhcp" aria-expanded="<?php echo $tab === 'piholedhcp' ? 'true' : 'false'; ?>" role="tab" data-toggle="tab">DHCP</a-->
                           </li>
                           <li role="presentation"<?php if ($tab === 'web') { ?> class="active"<?php } ?>>
                               <a href="#web" aria-controls="web" aria-expanded="<?php echo $tab === 'web' ? 'true' : 'false'; ?>" role="tab" data-toggle="tab">Web interface</a>

You have a pantload of connections on the Pi - which one have you configured for your DHCP server and clients to use?

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✗] Failed to resolve internationalguardianminute.com on eth0 (10.0.0.72)
[✗] Failed to resolve internationalguardianminute.com on eth1 (192.168.32.1)
[✗] Failed to resolve internationalguardianminute.com on eth2 (169.254.157.177)
[✗] Failed to resolve internationalguardianminute.com on eth3 (169.254.177.33)
[✗] Failed to resolve internationalguardianminute.com on lo (127.0.0.1)
[✓] doubleclick.com is 142.250.191.174 via a remote, public DNS server (8.8.8.8)

Our DHCP discover process did not find any active DHCP servers:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   Error: Could not bind socket to interface eth0 (Protocol not available)
   Error: Could not bind socket to interface eth3 (Protocol not available)
   Error: Could not bind socket to interface eth2 (Protocol not available)
   Error: Could not bind socket to interface eth1 (Protocol not available)

From a client that you believe should be connected to the Pi-Hole for DNS, from the command prompt or terminal on that client (and not via ssh or Putty to the Pi), what is the output of

nslookup pi.hole

nslookup flurry.com

nslookup flurry.com 10.0.0.72

You aren't running our shipped code:

im using pi hole for windows, i found it a few months back and the installation is a simple .bat file, followed by configuring, that's how i did it the last time and how i tried again

You have a pantload of connections on the Pi - which one have you configured for your DHCP server and clients to use?

i configured the pi-hole to use my computer as the pi-hole, nothing was said about dhcp during setup, only to set static, that IP would be 10.0.0.72

Our DHCP discover process did not find any active DHCP servers:

i dont know what this means, i did the same setup steps as before when i only had ipv4 and pi-hole worked fine, now i have ipv6 nothing works.

nslookup pi.hole result:

nslookup flurry.com result:

nslookup flurry.com 10.0.0.72 result:

also if you need the source of what im using, it is here: GitHub - DesktopECHO/Pi-Hole-for-WSL1: Ad-blocking DNS server for Windows • Unbound pre-configured • Deployment ready in minutes • Does not require hypervisor/docker

and i notice this line,
image

and this is the info given after running configuration.bat, my IP is static

image

It doesn't look like there is any support route for that version, and it's down to individuals to hack it to get it to work if they encounter any problems.

As jfb points out you have a huge load of network interfaces and IP addresses set up. Your Windows Pi-hole might be set up to use an IPv4 address and an IPv6 address, but it also needs to be able to act as a DNS server on your network so that your other clients can use it.

In your case the IPv4 addresses aren't working, the IPv6 address being used isn't routable, and there's no DHCP available to tell clients to use Pi-hole.

Do you have a Raspberry Pi computer, or even an old laptop you can install Linux on? It doesn't have to be anything powerful. If not, consider treating yourself to a Raspberry Pi with the official PSU and a SD card. That way you willl be able to install the official version which is supported here, rather than a third-party version which isn't supported here.

i could try to install linux on an old laptop, if that's the solution. I see pihub is sold out of the devices themselves, i assume this link shows the steps for a linux computer setup?

Yes, that is one method, but I prefer to download the install script and run it directly. I find it works more reliably on different OSes.

  • Go to https://pi-hole.net/
  • Click where it says Install Pi-hole
  • You'll see the same command as you link to above, but I go down a bit further...
  • ...and use Method 2 below that

I use The Pi Hut here in the UK, they do ship abroad if you are outside the UK. If you want to have a play with Pi-hole, an old laptop running a supported Linux is a great place to start.

Edit – forgot to mention there is an official Docker image (see same Pi-hole page) so if you use Docker then that might be an even easier way to get up and running.

Alright, thanks for the info, gonna be a bigger pain in the neck than i anticipated but ill try to get the device itself for simplicity sake

By all means don't give up on the Windows version, you may be able to get it going. Probably worth having another go with it. Clear up your networking so it's simpler, or use a different Windows machine that is set up more simply.

Make sure the Windows computer has an IPv4 address and you can ping it from other computers on the network. Then install it again and see how it goes. Tell it to not use IPv6 during setup, that should simplify things.

The general approach still applies. You have to tell clients on your network to use the Pi-hole, that is usually done using the DHCP server on your network. If it's working you'll see queries appearing in the Query Log.

Just be aware that it's not made by any of the developers here and is a bit out of date, so no-one here can really help if it's not working.

yeah i forced my windows computer to have that 72 address as static inside my gateway, i cant tell pi-hole setup to not use ipv6, it doesnt ask me, all it asks for is eth0-4 and i choose eth0 because that's the correct one, since i cant modify dns servers directly on my gateway i was simply entering the ipv4 of my machine (10.0.0.72) as primary dns on my other devices i wanted pi-hole on, and set them to static via gateway also, to no avail. Things worked and were much simpler before i had ipv6, but its not like i can disable it in the gateway, it's very limited it sucks.

update: i deleted the old .cmd file and downloaded it again anew, after a complete uninstall, ran the file and allowed it to install with default settings, i disabled all other network devices on my setup, virtual network devices and all, and it opted to use the proper eth0 and 72 ip i specified. I also opted to use level 3 DNS instead of cloudflare, and that's the only thing i changed, so i believe that may have been an issue, for whatever reason.

set the ipv4 dns on my phone and computer itself, and results are being shown and filtered.

The only oddity is that my pc is listed twice, as localhost and pihole, aside from that those 2 + my phone are listed as clients, yet it says 4 here

looking in the network tab there are only 3

Regardless, total wipe and reinstall + level 3 dns seems to have fixed it, for now at least.

1 Like

That's actually normal, localhost is the machine on which it's installed via the loopback interface, while pi.hole is a custom name internal to the Pi-hole via the configured address. From the point of view of the machine running Pi-hole, both are valid routes to and from the Pi-hole services.

ah i understand