Pi-hole not working the same on all my devices



I’ve installed Pi-hole on my Raspberry Pi and don’t get the same behavior across my different devices.
I can’t change the DNS directly on the router nor want to use the Pi as the DHCP server.
Therefore I’m simply entering the Raspberry Pi IP address in the DNS settings on the different devices.

I’m testing this with 4 different devices and this happens:

  1. macbook air: works as expected, no problem so far.
  2. windows 10 pc: starts working at the beginning then stops using the Pi.
  3. samsung tablet #1: works as expected, no problem so far.
  4. samsung tablet #2 (more recent model): doesn’t work.

I can’t figure out how some devices works fine and the others have trouble.
When running pihole -t to figure out what’s happening with the defective devices I can see it starts replying but then no data is coming as if it wasn’t using the Pi to resolve addresses anymore.
Meanwhile when trying to see the difference for a working device I can see the logs flowing and everything seems fine.

I’ve no idea from where I can start troubleshoot this issue. I’ve already cleared DNS cache on all devices and even restarted them.

If someone needs logs to help me with this I will be happy to provide.

Thanks for the help!


This FAQ may be of assistance.

Note that the router may also be providing a sneak path around the Pi-Hole.

Is there a particular reason you don’t want to use the Pi-Hole for the DHCP server?


Yes I’ve read that FAQ and changed my DNS the way describes on step 3.

I don’t want to use Pi-Hole for the DHCP server as I don’t want every devices to use Pi-Hole for now. Also I’m restarting my Pi every now and then and don’t want to break the home network when someone of my family is using it.

EDIT: on my Windows PC, I removed the second DNS address I had set to leave it blank (Windows doesn’t allow me to have twice the same ip). And it works!

I tried to do the same on my samsung tablet but even when leaving it blank or just setting my Pi address twice it doesn’t work. I guess it falls back to a third hard coded ip like in case they cant reach a host.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.