Pi-hole not working for all devices


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

pihole should work for all the devices

Actual Behaviour:

I have installed pi-hole on raspberry pi3 b+ (raspbian os), connected to my router via eth0.
Ads are being blocked if i browse on the rapsberry pi
However when i connect my mac on wifi, ads are not blocked
I have changed the /etc/resolv.conf on mac to have my pi-hole ip

$ cat /etc/resolv.conf
nameserver 192.168.1.24

$ nslookup pi.hole
Server: 192.168.1.24
Address: 192.168.1.24#53

Name: pi.hole
Address: 192.168.1.24

I have changed the DNS server on my router to point to pi-hole.
Interface listening behavior is set to Listen on all interfaces, permit all origins
Upstream DNS Servers configuration checked for OpenDNS.

Btw I want the router to manage DHCP rather than pi-hole

Any help appreciated, thanks.

Debug Token:

tikrk74sx6


#2

resolv.conf isn’t actually used or consulted in macOS for name resolution.

You do not need to manually set each device to use Pi-hole. It’s common to configure your router to hand out Pi-hole as a DHCP option. That said, there are three methods to get your devices to use Pi-hole. Have you read through this documentation?


#3

I have changed the /etc/resolv.conf on mac to have my pi-hole ip

Use the network preference pane on your Mac to select/check DNS. Network > advanced > DNS. This should show the IP address of your router, since this is providing DHCP services. The router is pointed to the Pi-Hole, so this is correct. Sometimes the router will pass the DNS address of the Pi-Hole and you will see the DNS of the Pi-Hole here instead. That is also acceptable.

Macs can hang onto old DNS settings for a while. To flush the DNS settings on your mac, run this command from the Mac terminal:

sudo killall -HUP mDNSResponder; sleep 2; echo macOS DNS Cache Reset | say


#4

Hi Jacob,
Yes I went through the documentation. I want to go for method 1. I did configure the pi-hole IP on the router, but i just checked again and it seems it is NOT the only DNS, though it is the first one.
|DNS1: |192.168.1.24|
|DNS2: |75.75.75.75|
|DNS3: |75.75.76.76|

Will this not work, as the documentation says the only DNS should be pi-hole?


#5

Thanks jfb, I did the change in the Mac settings, previously it was showing 3 DNS. Now I changed it to only the pi-hole IP. Also flushed using the cmd you provided, but i guess the main problem is still there. As i have mentioned in my other reply, the router still shows 3 DNS. I am trying to figure out if there is any way to force only the pi-hole as DNS on my router (Linksys E900).


#6

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.