Pi-Hole not serving wireless clients

I don’t think this is a Pi-Hole issue but I couldn’t find anything while trying to Google. I have Pi-Hole set up in a Debian VM on my ESXi server as the DHCP server for my LAN. Everything works perfectly for wired clients. Wireless clients connect to the network via an ASUS RP-AC68U access point and this is where the trouble arises. Wireless clients get all the correct configuration from the Pi-Hole DHCP, but for some reason they do not actually use it for DNS queries. Local name resolution doesn’t work, and ads are still displayed, however I’m still able to access the internet.

Now, the AP itself is configured correctly, it has some network troubleshooting tools built in, one of which is nslookup. Testing resolution with this works every time, but just to be sure I also tried manually setting the AP’s DNS servers to the Pi-Hole but experienced no change with wireless clients. I’m pretty confident the AP is doing something whacky here, but I don’t know where else to go or what else to do to troubleshoot.

If you are lucky, your clients are just holding on to an older DHCP lease with outdated DNS server information. Dis- and reconnecting them to the the WiFi network should solve this. Some stubborn smartphones might need a restart as well.

If that doesn’t fix it, you might be suffering from a strange misbehaviour on part of your acccess point:
Only a while ago, some ASUS network equipment (especially Asus AC68) were notorious for handing out themselves as DNS server in addition to any manually configured DNS server.

It seems some users were able to avoid this by filling every available slot with Pi-hole’s address. However, there seems to be no guarantee that this will actually make the router disappear as DNS server.

As a safe guard, you could also configure Pi-hole as your router’s upstream (WAN) DNS server, in addition to DHCP settings. On the downside, you should be aware that DNS requests arriving at Pi-hole in that way can no longer be associated with single clients.

Switching DHCP to Pi-hole would have been your best option, but:

That’s weird, as having made Pi-hole your DHCP server should have dealt with the problem, handing out DHCP correctly. Did you disable DHCP on your ASUS device?

I also have no idea whether this behaviour is limited to certain router models and (custom, e.g. Merlin) firmware versions only, nor whether ASUS as the router’s maker was made aware of this, whether a firmware update is available or even whether this problem still persists.

You could verify if your router is affected in this way by looking at cat /etc/resolv.conf on a Unix client or ipconfig /all | find "DNS"on a Windows machine. If your router’s IP shows up aside (or even instead of) Pi-hole’s, you are affected by this router problem.

In that case, it’s probably better to search for a solution on forums dedicated to your router’s version or custom software.

1 Like