Pi-Hole Not seeing DNS queries from other clients in network


Please follow the below template, it will help us to help you!

Expected Behaviour:

Ads should be blocking when using clients to browse web (Windows 10 PC and Android Phone)

Actual Behaviour:

DNS lookups from Windows and Android are resolving normally. Browsing web from the computer that Pi-hole is installed works properly; ads are blocked.

Debug Token:


I installed the latest version of Pi-Hole on my Intel Mac Mini running Debian 9. The IP address of the Pi-Hole server is I am able to connect to the web interface from other devices.

I changed the DNS server on the Windows machine to the Pi-Hole server, yet no ads are blocked.

When I run nslookup, I get:

From Windows:

C:\WINDOWS\system32>nslookup doubleclick.com
Server:  UnKnown

Non-authoritative answer:
Name:    doubleclick.com
Addresses:  2607:f8b0:400a:808::200e

When I run the same command from the Pi-Hole server:

dennis@dennis-macmini:~$ nslookup doubleclick.com

Name: doubleclick.com

Any suggestions on what is set improperly?


Do you see the DNS requests from the other devices in your query log or in /var/log/pihole.log?


No, I do not see and DNS requests from the other devices in the query log or in pihole.log

Even when I force an nslookup through the pi-hole server there are no entries.

C:\Users\Dennis>nslookup doubleclick.com
Server:  UnKnown

Non-authoritative answer:
Name:    doubleclick.com
Addresses:  2607:f8b0:4009:812::200e

I just ran that command from my Windows computer and there were no log entries. I’m confused how it returned though


If it doesn’t show up in /var/log/pihole.log, then Pi-hole did not receive the query, and the issue lies somewhere else in your network.


It returned this IP because the DNS request did not go through Pi-Hole. The domain doubleclick.com is blocked by the default Pi-Hole block lists. It is likely that your router is providing an alternate DNS path that bypasses Pi-Hole. If you are not actively using IPv6, disable this on your router and clients. This is a frequent source of bypasses.


So if I set my DNS server on my Windows 10 machine to be an non-existent device,, then no websites load.

However when I point the DNS server back to the pi-hole, then I can access websites, but ads are not blocked.

Does that help narrow down the issue?


Yes, a bit. When you say ads are not blocked, is this some ads are not blocked, or no ads are blocked at all?

What is the output of ipconfig /all on the Windows machine?

closed #8

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.