Pi-hole not installing on Ubuntu Server 20.04

The issue I am facing:
I have set up a server in order to install Pi-hole. I have configured static ipv4, but I am not able to install the Pi-hole properly, it's giving DNS resolution error.

Details about my system:
The server used is Ubuntu Server 20.04 (Image 1). And it's a fresh install, so I haven't configured anything apart from static ipv4.

What I have changed since installing Pi-hole:
I have changed nothing in the system. After running the shell script for the first time, "DNS resolution error" (Image 2) came up and exited the installation, so I again ran the script and some other error came up (Image 3). I tried the suggested step (Image 4) but it didn't make any difference.
I have generated the debug log: https://tricorder.pi-hole.net/pmz0fHPA/
Please help me in rectifying this issue.




Please generate a debug log, upload it when prompted and post the token URL here.

Your debug log shows your gravity database is empty:

*** [ DIAGNOSING ]: Gravity Database
-rw-rw-r-- 1 pihole pihole 92K Aug  2 03:29 /etc/pihole/gravity.db

*** [ DIAGNOSING ]: Info table
   property              value                                   
   --------------------  ----------------------------------------
   version               15                                      
   Last gravity run finished at:

Run from your Pi-hole machine, please share the output of the the following commands:

which timeout
pihole -g -f

A post was split to a new topic: Issue when installing on Ubuntu Server 20.04 in an EC2 instance