Pi-Hole not blocking anything


#1

HI, any help would be greatly appreciated.

Every time I’ve tried pi-hole I’ve had the same issue, now finally posting to try & solve it.
Fresh install of raspbian lite on a first gen pi. It installs fine, it runs, but blocks nothing.

I’ve had varying results of the web admin page, some installs it has data that changes, other times, it’s all 0% on every stat.

The one time I was successful in blocking anything, when the pi was switched off, I then got nothing on reboot.

I’ve also had the same problems with a Pi3 too.

Thanks in advance.

Debug token
z1du55gws2


#2

It looks like the Pi-hole install is working. How are you setting the IP address of the DNS server on the client devices?


#3

Thanks for your response. Good to know it’s something I’ve misunderstood.

Last night I set devices to use the dns of the pi.

I’ve thought I had it working just now by using the pihole dhcp settings, but no, still nothing.
& now I can’t even get to the web admin page or maintain a putty session.


#4

Can you ping the device? Is it set to have a static IP? How are the IP’s determined on your network?


#5

Sorry for going afk, not forgotten, life…

Pi was set to have a static address, but even when I did have it working that one brief time, when I shutdown the pi to move it to the router, it then didn’t work on boot, that install would have been static too.

From the pi, I can ping google, & another machine on the network. From another machine on the network, I can ping the pi.

IP are determined I guess automatically.

I hope this helps. I have just seen pihole 3.3. is released, you think a fresh install is worth a shot?

Again, sorry for the time it took for me to respond, & thank you for your responses.


#6

I would try a reinstall using Raspbian Lite Stretch (the latest).


#7

Lite Stretch is what I was using.

I tried a fresh installation last night. After reaching the same point where nothing is being blocked, I re tried everything multiple times.

Since disconnecting the pi from the network, I’ve had multiple issues that have caused problems on multiple machines. I can now no longer use open dns, & have to use google dns to get online. Automatic settings no longer work.

I’m at the point where I’m thinking my router is just rejecting the pihole settings, but I’m far from an expert…

Thoughts?


#8

First thing to check, is Pi-hole responding to DNS queries from a client.
Whats outcome from below one on a client PC (can be Windows or Linux) ?

nslookup pi.hole <PIHOLE_IP_ADDRESS>

Next, check if you get the same results if you run the same nslookup but leave out the “<PIHOLE_IP_ADDRESS>” bit.
Whats outcome of below one on a client PC ?

nslookup pi.hole

If results differ, maybe you get an “NXDOMAIN” reply for the “pi.hole” lookup, you’ve configured something wrong somewhere.
What are DHCP assigned IP details on a Windows client PC when run below one in a CMD box ?

ipconfig /all
*Am only interested in the DHCP and DNS bits.

Or if on a Linux client PC, what DNS server is configured/displayed (DHCP assigned or static) with below one ?

cat /etc/resolv.conf

Below link describes preferred/recommended configuration of the router:

If not possible because particular settings lacking on the router, you could disable the DHCP service on the router and as a replacement, activate Pi-hole’s DHCP service instead:


#9

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.