Pi-Hole not blocking ads - Please help

Sorry to be one of these guys, but after reading many forums and troubleshooting, I’m at a loss. I setup Pi-Hole a few weeks ago on an Ubuntu VM.
The router is set and pointed at both IPv4 and IPv6 addresses of the Pi-Hole only. No other entries. I tested with shutting off IPv6 with the same result.
Pi-Hole itself shows it is highly active and blocking, but ads still show-up everywhere. One example is speedtest.net, where the entire page is covered with them.

Router DNS settings:
image
image

Dashboard

Debug token:9gksf82brg

Your debug log shows that Pi-Hole is blocking properly, but you have multiple IPv6 addresses, none of which match your Pi-Hole setup. The IPv6 setting in your router may be providing a bypass.

** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the ens33 interface:
   192.168.1.100/24 matches the IP found in /etc/pihole/setupVars.conf

[✓] IPv6 address(es) bound to the ens33 interface:
   2600:8801:2c80:292:d575:e521:3315:ea48 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   2600:8801:2c80:292:c4d2:b58b:25b6:e434 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   2600:8801:2c80:292:2dbb:cfc3:aab9:f714 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   2600:8801:2c80:292:9570:8f13:b7f:b19c does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   2600:8801:2c80:292:2c8e:efee:96bf:f764 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   2600:8801:2c80:292:4dc0:bcb6:c492:25cc does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   2600:8801:2c80:292:9c92:4b3c:f834:f9b2 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   2600:8801:2c80:292:bb5a:1011:875d:f7be does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)
   fe80::70b7:47f5:b2d2:9dcd does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

Thanks for the reply. You’ve led me to an interesting finding. It’s only my laptop that’s not working. Everything else in the house is fine. I saw those address but figured they were just local. I cannot ping those address, nor do I understand how they are there. I disabled IPv6 with the same result. Can you explain to me what would cause those address to show up? Are they something other than what would be connected to my router? Interestingly enough, what led me to realize it was just my laptop was when I reset my server, my laptop still had internet access, like nothing was wrong. I flushed DNS and still going right through. I checked DNS settings on wifi properties, and it was set to “use the following” but it was blank. I manually set to pihole and they still come up, meaning my laptop is somehow the only thing bypassing it, even though it’s connected to the same network the same way. What would cause just one computer to bypass pihole even when it’s manually set to it and what causes those other IPv6 addresses to show up?
Thanks for your time.

EDIT: Setting up with Windows DNS settings set to PiHole is reflected on PiHole itself. It shows sites being allowed/blocked. I went to speedtest.net and all ads show up while they don’t on other PCs. This was the result of what was allow/blocked.
I checked out https://ads-blocker.com/testing/ and the same exact ads that show up on speedtest.net, which is something I forgot to mention, it’s always the same ads from googlesyndication, which is blocked. Pulling the pihole log even shows googlesyndiction blocked when I load the website, but they’re still loading somehow, just on this PC.
Interestingly, I have no ads on facebook, pausing pihole will cause them to popup. So it seems it’s random sites that use google, are normally all the same exact ads, and pihole is reporting them as blocked from what I can see.


Run ipconfig /all on the Windows machine and see which DNS servers are in use.

It’s pointed directly at Pi-Hole. I’m baffled, cause I see it working, it is blocking on this machine, but somehow Google is getting through, even though I see them getting blocked in pihole.

What about IPv6?

What browser are you using? Check the settings on the browser for DNS.

I’ve disable IPv6 and have left it off for a day now. I have tested on Chrome, Edge, IE, and Firefox (fresh install just for this), flushed DNS before using each, all with the same result and basically the same ads as each other. Once again, all google. Inspecting the element of the ad contains:

<div class="ad-container GoogleActiveViewElement" id="ad-container" data-google-av-cxn="https://pagead2.googlesyndication.com/pcs/activeview? href="https://www.googleadservices.com/pagead/aclk?sa=L&am id="product3-clickOverlay" href="https://www.googleadservices.com/pagead/aclk?href="https://www.googleadservices.com/pagead/aclk?sa=L image:url(https://encrypted-tbn1.gstatic.com/shopping? href="https://www.googleadservices.com/pagead/aclk?sa=image:url(https://tpc.googlesyndication.com/simgad/1o

While at the same minute from the same IP the following shows as blocked:

If you’re interested in seeing the entire log from when the page was loaded:

Well, I can’t believe it. In the back of my head I thought it was a virus, problem being, I’ve scanned with everything under the bluemoon and nothing. I randomly searched for “Adware DNS” and see a quick tool from Norton called “Remove Adware.DNS Unlocker Activity 2 from your computer” that is literally just a reg patch. Well … it’s stopped. It was adware, and now I find that my assumption from nearly a month ago that I was infected with something (I know exactly what it was) but couldn’t prove it was true. Now I get to wipe my computer, cause I’m assuming there’s something else that isn’t popping up.
Thanks for your help guys! I’ll be donating.