Pi-hole/Linksys Setup Assistance

I've searched through the forum here and Reddit, but still haven't found a solution. I am very new to this world of networking. I'm not sure if this is a Linksys issue or if there is something I have done wrong in the setup of Pi-hole.

Pi-hole Dashboard shows blocked queries but ads still getting through.

  • HP T420 thin client with Debian Server OS.
  • Spectrum provided modem
  • Two Linkysys MR7300 routers. One as router, one as node hard wired via Cat5.
  • Pi-hole v5.15.5

I have tried the following:

  • Gave Pi-hole static IP on server.
  • Gave Pi-hole static IP in DHCP reservations on router.
  • Designated Pi-hole IP as the only DNS server in DHCP settings on router. Left other fields blank.
    This did not work.
  • Manually gave one Windows PC and one Iphone the Pi-hole IP to use as only DNS server.
    This did not work.
    Did above plus:
  • Disabled Ipv6 on Windows PC ethernet adapter.
  • Disabled Ipv6 on router.
    This did not work.
    Did all of the above plus:
  • Disabled DHCP on router.
  • Enabled DHCP on Pihole.
    This did not work either.
  • I have also rebooted the server and clients multiple times.
    This did not change behaviour.

What is happening:
The Pi-hole Dashboard shows that it is blocking queries, but ads are still visible on both devices (and other devices not listed above).
I tried to troubleshoot using methods found in other posts.

  • Ipconfig /all shows dns-server as Pi-hole IP
  • nslookup pi.hole returns Pi-hole correct ipv4 address and a ipv6 address also.
  • nslookup flurry.com (Pi-hole IP) returns:
    Server: pi.hole
    Address: (Pi-hole IP)

Non-authoritative answer:
Name: flurry.com

Any assistance will be greatly appreciated. Thank you for a such a cool product! Mahalo in advance!

Debug Token: https://tricorder.pi-hole.net/jYgSYXut/

I think I may have found the issue. It was Avast. Avast has a feature called "Real Site" that is supposed to be some kind of DNS protection. It was forwarding my DNS requests to another server. As soon as I turned off the feature nslookup flurry.com (Pi-hole IP) returned But if there is any other issues in my Debug Token, I am all ears. Mahalo!

No problems noted in your debug log.

1 Like

Nice! Mahalo for the quick response!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.