Pi-hole isn't blocking

Expected Behaviour:

Have two access point set up and may be causing the problem.

Actual Behaviour:

Netgear Router + Netgear wireless router (access point) + Netgear extender (access point)
10.0.0.10 (Pi-hole)
DNS is set inside the router
It’s not blocking any ads; also blacklist a website and it didn’t block it.

Debug Token:

https://tricorder.pi-hole.net/ye9q7v8fmq

@superchuc What are the exact model numbers of each of your Netgear HW? Is the “Netgear wireless router” directly connected to the “Netgear Router” by Ethernet? Is the “Netgear extender” connected back to the “Netgear wireless router” by a wireless connection? Are both the “Netgear wireless router” & “Netgear extender” configured as bridges?

Thanks for the reply! I have a C3700-100NAS as my router (disabled the wifi) and R6700v3 as my main wifi. EX3700 is another wifi for my smart devices. Both R6700v3 and EX3700 is directly connected to the router. All Netgear devices are bridged together under the same subnet.

From a connected network client, run the following command from the client terminal or command prompt (and not via a ssh session to the Pi):

nslookup pi.hole

The reply should be from the Pi-Hole and the resolved IP should be the IP of Pi-Hole. If not, then the client is not using Pi-Hole for DNS.

The address is not the same as the pi.hole IP address (which it’s suppose to be 10.0.0.10). How would i fix this?

Again, thanks for helping!

First step - manually map the DNS for that client to Pi-Hole, then verify that the DNS queries are going to Pi-Hole.

If that works, then work on your router settings to get the network DNS assigned to Pi-Hole. Typically in the DHCP tab of the router.

i think i know why it didn’t work. i needed to clear the cache on my browser. i have set my pi-hole DNS automatically to my router so every devices that connect to my network should route to that DNS. everything is working now. thank you!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.