Pi-Hole is not working? why not

Hello all,

I am trying to configure my freshly installed Pi-Hole on my new Raspberry Pi3+


  1. Modem: DSL-AC87VG
  2. Raspberry Pi3+


  1. RaspbianOS + OS without recommanded apps.
  2. Pi-Hole installed.

But it does not work:

I have followed this Youtube link (to add as DNS): Asus Router SimpleTelly Smart DNS Setup - YouTube

Than the piece on the Pi-Hole site it self: How do I configure my devices to use Pi-hole as their DNS server?

To check if it works, i tried it on my IE11 http://simple-adblock.com/faq/testing-your-adblocker/ - still not working.

Please send us the token generated by

pihole -d

or do it through the Web interface:

The first Youtube video shows how to change the DNS on the router for the WAN interface. This is the Wide-Area Network, or coming from your ISP.

You need to change the DNS Server to the Pi-Hole's IP-address in the DHCP settings of the router. The video is very confusing and not helpful, probably the reason it's not working.

Alternatively, I'd strongly recommend testing the Pi-Hole first by manually changing the DNS-server in the settings of your phone or tablet before setting the home router to distribute the Pi-hole DNS through the DHCP. That way it only works on that single device allowing you to check if the problem is with the Pi-Hole or with the DNS settings on the router. If that works you can continue and change it in the router.

I'd also not recommend using that Ad-blocker tester URL. I have a Pi-Hole set up correctly and it still shows it as "not working".

I cannot do anything anymore i guess after changing the settings in my router i did it wrong??.

The DNS (pihhole) is the same as my router now. So when i try to navigate to my router it does not work ''page not found''

when i go to my win10 client enter the IP address not working.

here the debug: https://tricorder.pi-hole.net/60bqj5nb58

Hi all,

So the Pi-Hole has stopped a lot of ''blocked queries'' 3971. But how can i see what device and where it is coming from. And is it possible to see if works via my modem/router or not.

Apps as youtube or Ebay Kleinanzeigen are still showing ads how is that possible.

You can see the queries in the query log. If an ad comes from the same domain as the page content or uses randomized domains for both content and ads (youtube), then it is impossible to block via DNS.


I have checked the queries after work now. And i do not know if it setup correctly.
Indeed it blocked a lot of queries.

But i also added some blocklists from https://firebog.net/ to the Pi-Hole and i have the feeling it blocks most of those ads - things.

Here are the settings in the router, are they correct?

I have added the DNS server to my wifes phone, and my phone.
I am now thinking to add blokada app as well with the custom DNS to my DNS. but first it needs to be working.

Please upload a new debug log, and post the token (the first one has expired). We can check your Pi-Hole and tell you if the problem is there.

Here is the code, https://tricorder.pi-hole.net/svvxu8tetx!

One question who is having access for that token. and what is visible for all the people? how is that with the GPDR breach etc?

There are eight people in the world (all on the Pi-Hole team) who have access to the debug logs, and the token is the method to find the log in the Tricorder repository. Nothing is visible to anybody else. The debug log automatically expires in 48 hours and is deleted (which is why I requested a new one).

The debug log we see is what you see on your screen when you generate it.

Your debug log shows that Pi-Hole is working properly, receiving and resolving DNS queries from devices on your LAN. What indications do you have that Pi-Hole is not working properly?

  1. I have feelings like it is not blocking everything. Because i can see sometimes in apps like ebay or ebay-kleinanzeigen etc. Or in Youtube.
  2. can you also see if it goes pass by my router?

Because now i have added the DNS server to the WiFi of my wife and my self. But will i need to do this each time in order to get running? I am using several block lists, but sometime i have a complete blocked reset password mail, how can i unblock to not delete the hole list?

My list i use:
Blocklists used to generate Pi-hole's Gravity: 34
Enabled List Delete
Blocklist of hostnames and domains for blocking ads, trackers and others (format: hosts -- in hosts file format)

YouTube ads are difficult to block with a domain blocker (i.e. Pi-Hole). YouTube serves the ads from the same domains as the content, with frequently-changing sub-domains. There is a very long running thread on this topic here: How do I block ads on YouTube?

For the ads on other sites, these tools are useful to determine the domains from which the ads are being served. This will help you determine which domains to block:

We cannot see that in a debug log. The log shows the configuration and operation of Pi-Hole only, and does not diagnose any network issues.

No. Once you make this setting change, it should be persistent and not change.

I don't understand this question.

As you can see it's not blocked :frowning:

My question ( last one of the previous post is ) I have a game webshop where I buy games. I forgotten my password and did a request new one. But the change password request link was not working "blocked" nothing appeared. So I disabled my wifi and the link works so in those cases it works.
But now I want to know how can I unblock that site without impactibg the block list?

What exactly is not blocked that you think should be blocked?

I would start completely over. Wipe the Pi, reset the DSL modem and start fresh.

I understand that you'd like to block every and all advertisement on the internet and in order to achieve this I think you've added every blocklist that you could find online. From what I understand is that this also has blocked certain domains causing a password reset link to not work anymore. This is probably a result from all the 3rd-party blocklists blocking services by accident that your Gameshop uses.

Some ads on the internet can not be blocked. Really simply put, YouTube mixes the advertisement data with the video data so Pi-Hole can't discriminate between the data coming from the same domain.
Other apps and services are starting to catch on and will try to do this too, like eBay. After running a Pi-Hole on my home network, my VPN and somewhere else I can tell after a full year of use, it blocks 85-95% of all ads. I have never added any other blocklist. I only use those default in the installer and they have never given me any problem with sites not working or services being blocked.

Some ads will get through. 100% blocking might be possible but it will require you to understand Pi-Hole, its working principle and the relation with the services and used blocklists. It would also need you to edit block files and for instance unblock the domain/service that your gameshop uses for the password reset. Which in turn requires your knowledge to find out which service is being blocked. For me personally I could do that but I know it's a waste of valuable time to manually curate those lists for my situation if it could go from 85%-95% ads being blocked to 90%-95%. It's only going to be a marginal improvement for most people.

Seeing the problems you've had in the past I'd recommend forgetting it and just sticking with the default blocklists that come with Pi-Hole.

Also see other postings bout Asus routers misbehaving if used for DHCP:

Hi Jerry,

I followed 1 step of you ''Reset Pi + Pi-Hole''

So now again i have a fresh installed Pi-Hole. On my router the starting range is the range from the pi-hole. So everything should be going directly passed by the Pi-hole since the starting ip range is the same as the pi-hole. The strange thing is. When i have it on DHCP it says .253 as the DNS server; but that is not possible. how to change.

If the developers can check; https://tricorder.pi-hole.net/k5b6ss9bt9!

so all the blocklists are empty now.

I'd really recommend brushing up some knowledge on how networks are managed and what DNS does, what DHCP manages and what settings are essential for the good operation of a network.

I really can not understand what you're trying to say or what you've done. I really don't understand what IP-ranges have to do with anything.

Normally your router does the DNS ánd the DHCP services. The DHCP hands out the IP-addresses and DNS does the website-name-to-IP resolving. In a normal situation your router will hand your Raspberry Pi an IP-address from within the set address pool. Only if you have more devices than IP-addresses in the pool (for instance 50 devices while the IP range is only 192.168.178.[0-30]). Normally the IP Pool should be something like 192.168.x.[0-255]. The IP-address that is handed out by the routers DHCP server has to fall within the IP Pool anyway otherwise it would never work either.

First you have to set the Pi-Hole to a static IP. This still has nothing to do with IP-ranges or whatsoever. This is done correctly as I saw in the screenshot below the IP Pool captions. A static IP is something different from telling the DHCP server to use the right DNS-server on the network.

Then you tell the router to use your Pi-Hole DNS Server in the DHCP settings instead of the internal DNS Server on the router. Looking once again at that screenshot you posted (with the IP Pool stuff) it seems to me that your router does not support setting a different DNS Server when using the routers DHCP server. I don't have experience with that router, nor can I see enough of all the different settings pages to make a 100% correct conclusion about this.

I'd really recommend leveraging the Pi-Holes' built-in DHCP server to have the Pi perform this operation instead of the router.

Hi thank you for your reply.

The problem now is solved for the most part.

I have a pool 1-14 is for servers and DNSsen
I have a pool 15-150 for subnets etc.

  1. Static IP is assigned to my pihole
    First re-installed my raspberry
    via sudo nano /etc/dhcpcd.conf
    interface eth0
    static ip_address=
    static routers= my router
    Installed pihole

  2. So i have modifed the WAN to give me the DNS option to add,
    Because on my router in LAN there is no DNS option.

Now i need to check if it works perfectly,, ( https://tricorder.pi-hole.net/27z6uzx2h0! )

I see the range, and i check the ip and i see my wifes IP of her phone.
And its blocking the most.

But when i use the dashboard i see its blocking because of the choosen DNS server is have used OpenDNS is this normal, or should it go differently..

When i run for example tracert google.com in CMD, its goes just by my router, but NOT DNS.
And on ipconfig /all i see DNS servers is my routers IP not the pi-hole.