Pi-Hole in Docker in PROXMOX ....funktioniert aber noch nicht?!

Moin,

ich habe Pi-Hole (und einige weitere Applikationen) in Docker (und einen weiteren LXC Container) in PROXMOX installiert. Das ganze läuft auf einer gejailbrakten Chromebox 3.
Die Pi-Hole Administration unter http://192.168.178.30/admin/ funktioniert.
Ich habe einige Adlists hinzugefügt, und davon wieder einige deaktiviert, so dass ich aktuell auf ca. 10 Millionen geblockte Domains komme.

Leider gelingt es mir nicht, dass Pi-Hole die Domains auch wirklich blockiert.
Ich habe in der Fritzbox unter -> Heimnetz -> Netzwerk -> Netzwerkeinstellungen -> IPv4-Einstellungen. Unter „Lokaler DNS-Server“ (Standard war 192.168.178.1) habe ich nun die IP vom Pi-Hole eingetragen: 192.168.178.30

Im Pi-Hole habe ich unter -> Settings -> DNS -> Upstream DNS Servers -> Custom 1 (IPv4) -> 192.168.178.1 (IP Adresse von Fritzbox) eingetragen.

IPv4 Primary und Secondary Cloudflare (DNSSEC) war gesetzt, habe ich gelöscht.
Nur IPv4 Secondary OpenDNS habe ich gesetzt.
Advanced DNS settings:
habe ich deaktiviert: Never forward non-FQDN A and AAAA queries
habe ich deaktiviert: Never forward reverse lookups for private IP ranges

Das Ergebnis ist: Alle Webseiten und auch einige Pi-Hole Testseiten werden weiterhin mit Werbung geladen. Offenbar wird nichts geblockt.

Wo liegt der Fehler?

Danke und beste Grüße,
Chris