Pi-Hole in Docker in PROXMOX .... but does not work yet?!


I have installed Pi-Hole (and some other applications) in Docker (and another LXC container) in PROXMOX. It runs on a jailbroken Chromebox 3.
The Pi-Hole administration at works fine.
I have added some adlists and deactivated some of them, so that I currently have about 10 million blocked domains.

Unfortunately, I can't get Pi-Hole to actually block the domains.
In the Fritzbox under -> Home network -> Network -> Network settings -> IPv4 settings. Under "Local DNS server" (default was I have now entered the IP of the Pi-Hole:

In the Pi-Hole I have entered under -> Settings -> DNS -> Upstream DNS Servers -> Custom 1 (IPv4) -> (IP address of my Fritzbox).

IPv4 Primary and Secondary Cloudflare (DNSSEC) was set, I deleted it.
I only set IPv4 Secondary OpenDNS.
Advanced DNS settings:
I have deactivated: Never forward non-FQDN A and AAAA queries
I have deactivated: Never forward reverse lookups for private IP ranges

The result is: All websites and also some Pi-Hole test pages are still loaded with advertisements. Apparently nothing is blocked.

Where is the error?

Many thanks and best regards,

Please don't open multiple topics for the same issue.