Pi-Hole has 2 IPs, 1 static, and it grabs another via DHCP - please help

Please follow the below template, it will help us to help you!

Expected Behaviour:

No DHCP IP should be assigned as I’ve assigned a static IP during the PH config.
Running PH on Ubuntu in HyperV. If the VM crashes, when it comes back PH stops working properly.

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:15:5d:05:fd:0c brd ff:ff:ff:ff:ff:ff
inet 192.168.5.243/24 brd 192.168.5.255 scope global dynamic noprefixroute eth0
valid_lft 86349sec preferred_lft 86349sec
inet 192.168.5.33/24 brd 192.168.5.255 scope global secondary noprefixroute eth0
valid_lft forever preferred_lft forever
inet6 fe80::a1dd:6fd9:814b:f04f/64 scope link noprefixroute
valid_lft forever preferred_lft forever

Actual Behaviour:

[PH machine has 2 IPs, 1 static and grabas a 2nd via DHCP]

Debug Token:

[l1v2o8i3go]

I’ve seen that with Network Manager.

You’ll have to go in and manually set the IP in there in order to retain it.

I believe Network Manager is ignoring the dhcpcd.conf file.

Thanks for the info, but the issue is that I want to set the upstream DNS servers via PH, I may want to change them from google to open DNS or something - isn’t this going to just bypass that?

PH should really not be supported on Ubuntu 18.0.4 LTS if it’s not really supported properly; it just defeats the purpose of configuring this info from PH if I have to manually override it on the OS no?

I can switch to a different distro if someone would tell me which one would have the smallest footprint to run; the only reason I ran Ubuntu is that it was in the Windows easy VM deployment list/quick create.

Thoughts?

I honestly had/have the same problem with my Ubuntu machine.

Never understood WHY (and didn’t actually investigate it properly) as my scenario, requires that Ubuntu machine to have that one IP.

While Pi-hole works as it assigns a DHCP IP, I didn’t research to see why Ubuntu does that. It puzzled me for a couple of days 'till I did the above step.

It’s definitely OS related, as none (out of my >40) other devices constantly connected are doing this.

I do believe it’s related to Network Manager and how it works within the OS.

I personally noticed this on xubuntu.

Not sure what you mean by this tho.

Are you pushing specific DNS’ to the clients ? As in some clients based on the DHCP 6 (DNS) setting get and use different DNS’ ?

If you set-up your Upstream resolver in Pi-hole to whatever you chose, your client will not see that as the only DNS resolver (in order to retain a solif ad-blocking experience) shoulr be Pi-hole.

Your Pi-hole upstream DNS setting have no connection to the client.

In your first reply, you have a screen that shows the static IP that’s manually entered for Ubuntu; there is also a field there for DNS servers. But in the PH config, there are many upstream servers that can be selected as the upstream server, as the Ubuntu machine running PH becomes your network DNS “proxy” right?

So if I manually set DNS servers as in the picture you provided, won’t this override the upstream DNS servers selected in PH?

This is my confusion. I thought PH actually manipulated the OS (Ubuntu in this case) network settings. Assuming I entered the two you list (just trying to show my point) in your picture, but then I go into the PH interface and select Google and Cloudflare, will the 192.x DNS IPs be overriden by the Google and Cloudflare selected in PH?

If this is an Ubuntu OS issue I would happily switch to another linux version, or maybe Ubuntu 19 doesn’t have this problem…