Pi-hole fails to update FTL

Expected Behaviour:

Tried to update Pi-hole with "sudo pihole -up"
Also with:
wget -O basic-install.sh https://install.pi-hole.net
sudo bash basic-install.sh

Choosing the update option. Either way the update fails when it gets to update FTL.
I'm running it on a HP t5740 thin client

OS: Debian GNU/Linux 9.9 (stretch) i686 
Kernel: 4.9.0-7-686-pae
pihole -v
  Pi-hole version is v5.3.1 (Latest: v5.3.1)
  AdminLTE version is v5.5 (Latest: v5.5)
  FTL version is v4.3.1 (Latest: v5.8.1)

I found a similar issue here: FTL update fails: Downloading and Installing FTL...curl: (3) bad range in URL position 98 · Issue #3430 · pi-hole/pi-hole · GitHub
but in my case the 'basic-install.sh' seems to be right in "/etc/.pihole/automated install/"

Actual Behaviour:

  [i] Checking for updates...
  [i] Pi-hole Core:     up to date
  [i] Web Interface:    up to date
  [i] FTL:              update available

  [i] FTL out of date, it will be updated by the installer.

  [✓] Root user check                                                                                                                                                                                                                                                                                                                                                                                                             

  [✓] Update local cache of available packages
  [i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u3
  [i] Performing unattended setup, no whiptail dialogs will be displayed

  [✓] Checking apt-get for upgraded packages... 137 updates available
  [i] It is recommended to update your OS after installing the Pi-hole!

  [i] Installer Dependency checks...
  [✓] Checking for dhcpcd5
  [✓] Checking for git
  [✓] Checking for iproute2
  [✓] Checking for whiptail
  [✓] Checking for dnsutils

  [✓] Supported OS detected
  [i] SELinux not detected
  [i] Performing reconfiguration, skipping download of local repos
  [✓] Resetting repository within /etc/.pihole...
  [✓] Resetting repository within /var/www/html/admin...
  [i] Main Dependency checks...
  [✓] Checking for cron
  [✓] Checking for curl
  [✓] Checking for iputils-ping
  [✓] Checking for lsof
  [✓] Checking for netcat
  [✓] Checking for psmisc
  [✓] Checking for sudo
  [✓] Checking for unzip
  [✓] Checking for wget
  [✓] Checking for idn2
  [✓] Checking for sqlite3
  [✓] Checking for libcap2-bin
  [✓] Checking for dns-root-data
  [✓] Checking for libcap2
  [i] Checking for lighttpd (will be installed)
  [✓] Checking for php7.0-common
  [✓] Checking for php7.0-cgi
  [✓] Checking for php7.0-sqlite3
  [i] Checking for php7.0-xml (will be installed)
  [✓] Checking for php7.0-json
  [i] Checking for php7.0-intl (will be installed)
  [i] Processing apt-get install(s) for: lighttpd php7.0-xml php7.0-intl, please wait...

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

  Unable to complete update, please contact Pi-hole Support

Debug Token:


You have a lot of available updates. Before you update pihole update the OS:

"sudo apt update && sudo apt upgrade"

now try

"sudo pihole -up"


No sudo required. pihole -up will do it.

Already did before opening the thread, but I just noticed it didn't find a couple of the packages.

I needed "sudo apt-get upgrade --fix-missing"

It still doesn't find PHP

E: Failed to fetch https://packages.sury.org/php/pool/main/p/php-defaults/php-common_70+0~20190814.17+debian9~1.gbp1e7da2_all.deb  404  Not Found
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php7.0/php7.0-readline_7.0.33-10+0~20190807.18+debian9~1.gbp5452d8_i386.deb  404  Not Found
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php7.0/php7.0-json_7.0.33-10+0~20190807.18+debian9~1.gbp5452d8_i386.deb  404  Not Found
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php7.0/php7.0-sqlite3_7.0.33-10+0~20190807.18+debian9~1.gbp5452d8_i386.deb  404  Not Found
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php7.0/php7.0-opcache_7.0.33-10+0~20190807.18+debian9~1.gbp5452d8_i386.deb  404  Not Found
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php7.0/php7.0-cli_7.0.33-10+0~20190807.18+debian9~1.gbp5452d8_i386.deb  404  Not Found
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php7.0/php7.0-cgi_7.0.33-10+0~20190807.18+debian9~1.gbp5452d8_i386.deb  404  Not Found
E: Failed to fetch https://packages.sury.org/php/pool/main/p/php7.0/php7.0-common_7.0.33-10+0~20190807.18+debian9~1.gbp5452d8_i386.deb  404  Not Found

And still can't update FTL

You need to fix this problem. I would visit a forum for your OS. After you have apt update and apt upgrade working normally, then the Pi-hole updater will work properly.

Looks like I'll have to live without web UI for a while. After some tinkering I ran out of space on the 2GB SSD so bad I can't even uninstall stuff anymore.

/usr/bin/mandb: can't create index cache /var/cache/man/4121: No space left on device

I already ordered a 64GB one earlier today, so this is only a problem for a few days.

You could consider running the following commands to get some breathing space:

sudo apt-get autoclean

or, if that's not enough:

sudo apt-get clean

This may well free some hundred MBs by removing package versions from your apt cache (keeping the most recent ones or wiping them all) at the cost of having to download stuff again if you later choose to reinstall or reconfigure a package.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.