Pi-hole diagnostis long term load

Dear Community,

A friend of mine just gave me a raspberry pi B+ to make another pihole. It's seems there's an issue with the loading time

Here the diagnosis

Long-term load (15min avg) larger than number of processors: 1.0 > 1
This may slow down DNS resolution and can cause bottlenecks.

Here the generate token https://tricorder.pi-hole.net/6jsUk3b0/

IS there's any way to solve that issue ?

This is a really low-power device. The warning basically says you that the load on the machine is on the order of what the device can offer. Looking at your debug log, it seems to barely keep up but if you add some more clients (or in general activity) on your network, it may simply be too much for this little device.

There isn't really anything you could do except replacing the device with a more powerful one. Maybe disabling the query database can bring you some reduction in workload (but probably it won't matter).

Thanks my friends for the follow up. Maybe in the prerequisite tell the version of raspberry pi that could be supported. I didn't even started to use that pihole as DNS filter and it's already too slow. I will probably use that raspberry pi as a decoration. I don't know what it could be use if it'S can't even run a pihole.

thanks again for your support and help

with best regard

You should not read that as a general assessment of RPi B+ being inadequate for Pi-hole.

A first generation RPi B+ is a bit less performant as a Zero, which is quite capable of running Pi-hole. (Indeed, my own first RPi was a B+ as well, and it is still serving as a Pi-hole in a friend's home network without a speck to date.)

I think it's too early to retire your RPi B+, as your debug log does not indicate a high amount of DNS traffic:

   [2024-01-30 06:15:20.431 474M] Imported 24 queries from the long-term database
   [2024-01-30 06:15:20.432 474M]  -> Total DNS queries: 24
   [2024-01-30 06:15:20.433 474M]  -> Cached DNS queries: 16
   [2024-01-30 06:15:20.433 474M]  -> Forwarded DNS queries: 8
   [2024-01-30 06:15:20.433 474M]  -> Blocked DNS queries: 0
   [2024-01-30 06:15:20.434 474M]  -> Unknown DNS queries: 0
   [2024-01-30 06:15:20.434 474M]  -> Unique domains: 4
   [2024-01-30 06:15:20.434 474M]  -> Unique clients: 1

If that is accurate, this would suggest that your observation is caused by something other than DNS requests overwhelming your Pi-hole.

I see ... any suggestion to solved that issue ? It's a raspberry pi that I only installed the newest image of raspberry PI OS (the one with debian 12). I wasn'T able to have an internet connexion throught the ethernet port even if I got 2 lights (solid orange, and flashing slowly green). SO I put an external network card that was automatically recognized.

I've made the update and install the pi hole ... nothing else has been install.

thanks again for your help

N.B. I didn't set that pihole as DNS server yet, so that'S why theres not high amount of trafic .. before using it I wanted to solved that issue. Since I think I have solved the issue from my pi hole from my pi zero, I will probably give ti to my sister in law who got huge problem with her autist daughter.

The debug log only shows a small part of FTL logs, but apparently the warnings about excessive load only happened during an hour or so (from 6:20 until 07:35):

[2024-01-30 06:20:20.969 474/T495] WARNING: Long-term load (15min avg) larger than number of processors: 1.1 > 1
[2024-01-30 07:30:20.777 474/T495] WARNING: Long-term load (15min avg) larger than number of processors: 1.2 > 1
[2024-01-30 07:35:20.114 474/T495] WARNING: Long-term load (15min avg) larger than number of processors: 1.0 > 1

The load increased up to 2.1, then decreased below 1.0 after 7:35. No more warnings after that. Your Debug log was generated at 16:41.

This is a guess (maybe I'm wrong), but maybe there was something else running at that time, causing the excessive load.

1 Like

I've made a sudo apt update than sudo apt full-upgrade ... it took awhile, so i guess the pi was working hard.

Ive generated the log after delete one error and doing that update/upgrade

If after deleted a error, you still generate the same error its the update... else, i don't know what it could be

There are three versions of Pi OS. If you're not already, try re-imaging the card with the Lite version. This is a minimal build which does not have a desktop and does not have the extra packages (such as LibreOffice) installed. It boots to a terminal and you can still SSH in (if you're not using a keyboard and screen attached). This build is enough to install Pi-hole, which you will then access in the normal way via a web browser. It will help lessen the load if you've been using the fuller versions so far.

Edit to add – if you've already set up Pi-hole but want to try this, use Settings > Teleporter to take a backup which you can then restore later from the same place. That wil save you having to redo any lists and rules you've added.

Dear friend,

I already on the lite version (the one without GUI), already got a fix ip that i can connect with ssh
... ssh is working without issue except it's long to wait compare on my other pi ..

So it's already in the lightest way it could be ... i didn't overclock the pi (might be the last resort)

Apparently your device is able to run Pi-hole.

Are you still seeing warnings about excessive load?

If not, it seems you just saw the result of some process (probably the update commands) causing a temporary excessive load. This is expected in a low-power device, like an almost 10 years old Raspberry Pi B+.

That could explain a period of high load, and as rdwebdesign points out, that would have only be a temporary occurence.

Run on your Pi-hole machine, what's the output of the following commands:

iostat -c

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.