Pi-Hole DHCP issues with ISDN-Adapter (phone)

Devices:

  • Speedport Smart Router (Deutsche Telekom AG)
  • Speedport ISDN-Adapter for phones
  • Raspberry Pi with Pi-Hole
  • Other network devices

With DCHP turned off on the router and enabled on the pi-hole i expected all local network devices to use the pi-hole as dns server which they probably do.
All “normal” internet devices get the dns filter from the pi-hole as expected.
Problem: ISDN Adapter doesn’t connect to the provider’s servers any more! (even with the pi hole filter turned off)

With DCHP enabled on the router and disabled on the pi all devices work properly. The issue with this solution is that I’ve to manually configure each device to use the pi as dns server. In order to solve this I tried to set the pi as the default dns server of my router (pic1).


Surprisingly, this didn’t change anything.

I also don’t think that I’ve configured something wrong in terms of the dhcp settings because all normal devices are working. Just ask, if you need more details on the config.

If you have an idea what might be wrong, you’re free to tell me :smiley:

Thank for your help.
rnholzinger01

I had a similar configuration myself and everything was working fine. Similar, not the same because my equipment was

  • Telekom ISDN device (I guess this one)
  • Telekom Speedport W 724V Typ B (Firmware Version 01011603.07.001)
  • Raspberry Pi with Pi-Hole

I had exactly the configuration you describe running (DHCP server on the Pi-hole) without any extra configurations for the ISDN device and this worked without any problems for more than two years. We recently switched to using Alcatel VoIP phones directly, so we disconnected our ISDN box and sent it back to Telekom.

I’m not sure if the different router is really the difference, but what do you mean by

Do you mean:
a) Didn’t change anything = ISDN box still not working and ll the devices are using the Pi-hole
b) Didn’t change anything = All the devices are not using the Pi-hole and ISDN box working
c) Something else
?

Hmm… Maybe I should try setting up DHCP again from scratch. If I’m lucky, it’ll work then.

I kind of meant b*:
All devices are not using pi-hole except the manually configured ones AND ISDN box working (but obviously without DHCP)

Okay, so we can only assume that setting some internal IPs as DNS servers (as per your screenshor) does not do anything. This doesn’t come all that unexpected. I had an even older Speedport before this one (which turned up in magic smoke at some point and was replaced) and there you were not even able to set anything DNS related…

Yea, I’m generally not a great friend of these speedport routers, too.

I’ve just set up DHCP again and now surprisingly the ISDN Adapter works just fine.
If in case something will go wrong the next days I’ll come back to you.
Thanks so far.