Pi-hole Dashboard/Web Interface won't launch in MS Edge

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi-hole launch web interface in latest version of MS Edge

Actual Behaviour:

Get an error on Edge page as follows:

Check if there is a typo in pi.hole.

  • If spelling is correct, [try running Windows Network Diagnostics].
    DNS_PROBE_FINISHED_NXDOMAIN

Address loaded in Edge is http://pi.hole/admin/index.php
Favorites bar link is http://pi.hole/admin/index.php

When I click the Favorites bar link in Chrome which is http://pi.hole/admin/index.php page loads but in address bar the link renders http://192.168.1.104/admin/index.php and loads.

When I load as IP address of Pi-hole Edge will load the page. http://192.168.1.104/admin/index.php

Seems like Edge doesn't convert pi.hole/admin/index.php to IP address, whereas Chrome does.

Debug Token:

jtud98h4bu

It is possible/likely that Edge is using a private DNS of some sort, and the DNS queries from that browser don't go to Pi-hole.

From the PC command prompt (and not via ssh or Putty session to Pi-hole), what is the output of the following:

nslookup pi.hole

No problem on my PC. FF & Edge Chromium work same same.

Not really sure what this does but setting by default is disabled.
When I enabled setting Pihole subsequently loaded the dashboard no problem and a couple of tabs that had the error message I posted in initial question all refreshed and loaded dashboard.

http://pi.hole/admin is not served over HTTPS and there are no certificates involved at all. lighttpd doesn't even listen on port 443 with our configuration files.

That leads me to think you have set up some sort of proxy in front of Pi-hole or your network is using something to intercept HTTPS traffic and is not configured correctly.

Pi-hole is working fine. The web interface just won't launch in Edge. Launches fine in Chrome. It's an Edge thing, not a Pi-hole thing.
I initially set up in Chrome and it shows up just fine in Chrome. I just read an article that Chrome is getting loaded up with extra junk that eat up resources + all the tracking overhead. Article said Edge more slimmed down and is better option on laptop/desktop and has a lot of privacy protections built in that Chrome is lacking.
I just happened to try and crank up Pi-hole in Edge and saw that web interface wouldn't launch.

Microsoft Edge
Version 90.0.818.49 (Official build) (64-bit)

Microsoft Edge
Version 90.0.818.51 (Official build) (64-bit)
Mine doing fine now. I messed with it on and off for a couple of days of consistently getting that fault before asking question. What is significance, if any between pi.hole and pihole?
I did nslookup pi.hole which was recommended and I kept getting some domain error whereas I did nslookup pihole and it kicked out pihole IP address. Now I can do pi.hole or pihole and yields the pihole IP address. That being said. my router doesn't fit neatly in to the setup instructions given.

Pi-hole is configured to respond to pi.hole and does not know what pihole is unless you've made your own modifications and changes.

nslookup pi.hole
Server:  OPNsense.lan
Address:  192.168.88.2

Name:    pi.hole
Address:  192.168.88.5

nslookup pihole
Server:  OPNsense.lan
Address:  192.168.88.2

*** OPNsense.lan can't find pihole: Non-existent domain
dan@Viking-1:~$ dig +short pi.hole
192.168.88.5
dan@Viking-1:~$ dig +short pihole
dan@Viking-1:~$

who knows

I don't know. I just followed automated install instructions, Did best I could figure out with router setup. Other than that all I do is periodically look at query logs add domains occasionally.
I don't change names like pi.hole vs pihole because I have no way of knowing how many places in code are references to pi.hole.
No worries.

-rw-r--r-- 1 root root 138 Apr 25 03:55 /etc/pihole/local.list
   192.168.1.104 pihole
   2606:<SNIPPED>:5bcd pihole
   192.168.1.104 pi.hole
   2606:<SNIPPED>:5bcd pi.hole

It looks like you may have given the name pihole to the Raspberry Pi and this was included in the local.list so you could reach the Pi device by the name you had given it. As a comparison, this is mine:

dan@raspberrypi:~ $ cat /etc/pihole/local.list
192.168.88.5 raspberrypi
192.168.88.5 pi.hole

Pi-hole's admin interface is designed to only work with pi.hole or the bare IP address of the host.