Pi-hole Dashboard Not Displaying Anything

Hi Pi-hole community! I’m currently dealing with a bizarre issue where nothing is being displayed in my dashboard, and I was wondering if anyone here might be able to diagnose and solve the problem. I’ve searched far and wide for a solution but none of the troubleshooting suggestions have worked. If anyone here can help, I’d greatly appreciate it. Alright, here goes!

Expected Behaviour:

Dashboard displays metrics and graphs correctly instead of null values and spinning arrows

Actual Behaviour:

No metrics or graphs are displayed. Spinning arrows never stop spinning. Image for reference: https://imgur.com/9Gd3E2c

Debug Token:

https://tricorder.pi-hole.net/ndegj3clih

Additional deets that may help:

  • Pi-hole version: 4.3.2

  • AdminLTE version: 4.3.2

  • FTL version: 4.3.1

  • Have tried running a reconfiguration (pihole -r) where logging was enabled and all recommended settings were used; no luck

  • Pihole status indicates DNS service is running and Pi-hole blocking is enabled

  • Running pihole -t indicates stuff is happening

  • Static IP of [192.168.1.8] assigned to PiHole, which matches the IP address in the admin page’s Settings page

  • Issue is persistent across multiple clients and browsers, including a 2013 Macbook Pro running Catalina and using Chrome and Safari, a PC running Windows 10 and using Chrome and Edge, a 2018 Macbook Air running High Sierra and using Chrome and Safari, and iOS devices running iOS12 and iOS13.

Thanks in advance!

If you open the dev tools (F12), do you see anything in the console?

Looks like a lot of errors: https://imgur.com/zX9ooKE

Thoughts?

Open the network tab in the dev tools, select the JS filter, and refresh the page. Share a screenshot of the dev tools and check if any of the requests failed.

For some reason, a core library (jQuery) is not being loaded. Maybe the request for the code is failing, or the response is empty.

Here’s a screenshot of what you asked for: https://imgur.com/XyrdJCt

With this issue being persistent across multiple machines, different browsers, and different operating systems, it’s gotta be something in the pi-hole setup, right?

Please check the “disable cache” button and try again. The issue could be caused by many things, and this will help find that cause by determining why the library is not loading.

Here ya go: https://imgur.com/Kj9Hd7S

It is odd that multiple files have the same file size of 346B. Run this command on the Pi-hole device to see more about what is being returned:

curl -i http://localhost/admin/scripts/vendor/jquery.min.js

You can double check this by looking in the request details on the networking tab (from your screenshot, click on an entry).

When clicking jquery.min.js, jquery-ui.min.js, and bootstrap.min.js, i get a “Nothing to preview” in the preview screen, as seen in the screenshot below:

Did you want to see the output of the curl command?

Yes, please share the curl output