Pi-hole cutover from VM-Raspberry

Hello all - been using pihole since about last May, started out with a VM running DietPi as a sort of proof of concept and I liked it enough to go all in on a Raspberry. The new build is working fine although there is one oddity that I am not able to figure out.

In the previous version I had on the VM - 5.10 - it picked up my Brother printer and I was glad to learn about the telemetry going on there and let pihole do its thing. With the new version 5.15 on the Raspberry the same printer is listed under Tools > Network as "Device does not use Pi-hole"

I would rather not be sending info from my printer (for crying out loud!) to some third party without my knowledge so I started troubleshooting. Here is what I found:

The printer has a static IP address for my network use and works without issue. While I do not see any way to force it to use piholes DNS I did make sure the default route (gateway) is in fact pihole, just like all the other devices that work. In fact I didn't change anything on the printer, it worked fine in 5.10 but not with 5.15. The static IP is no issue, it is in a range I have dedicated to static IPs so there are no conflicts. And again, nothing changed on the printer - the only change was pihole.

Just to be sure I power cycled the printer (more than once) and I was under the impression that as long as the first hop is Pihole it should be doing its thing, but its not.

What else can I look at?


Pi-hole is not the gateway, it is the DNS server. The router is the gateway.

Ah yes, I mispoke :slight_smile:

Since the printer default route is pi-hole like all the other devices - I am still confused as to why it is not being used? And the fact that nothing changed on the printer confuses me. With 5.10 it was using the router as the default route, and that wasn't working so i changed it to use pi-hole - still not working.

In other words, if I point the printer at the AT&T router - device not using pi-hole. (but for some reason it did with 5.10)
If I point it to pi-hole - device not using pi-hole.

What else can I look at?

I have not been able to resolve this, does anyone have any thoughts on where I can go from here?

Any help appreciated,


For whatever it's worth, I have a Canon laser printer on my network configured to use my Pihole's IP address for DNS, and according to the Network Overview page on the Pihole web site, it has never made a query to Pihole (I've had the printer for over a year). My printer, like yours, has a static IP as well.

It's never had a problem printing; I assume it's never tried to perform a DNS query, since my firewall prevents any DNS queries that don't go to the Pihole. If you're worried about traffic from your printer getting out, you can do like I did and block port 53 traffic that's not bound for Pihole or just block any non-LAN traffic from your printer, I suppose. All Pihole can do is see DNS queries.

Good point, I didn't think of that and it sounds like a better solution anyway. Its just a bit of a head scratcher to me, in that with my old setup I did not lift a finger and happened to notice my printer talking to brother.com when in my view - its just a dang printer for my personal use, what in the world is it doing sending out info? So was glad to see it so I could block it.


I hear you, I've recently gotten a more robust firewall that reports more of what's being blocked. The number of devices on my LAN that try to bypass Pihole and directly query (Google) is annoying, to say the least.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.