Pi Hole crasht alle paar Stunden

Liebe Leute,

ich habe es als Neuling in diesem Gebiet endlich geschafft, Pi Hole im Heimnetz zum Laufen zu bekommen, ABER:

  • Modenrouter: TP Link Archer vr600

  • Raspberry Pi 4 mit Raspbian und Pi Hole 4.3.2

  • Jedes Gerät hat eine fest zugewiesene IP, auch der Pi

Heimnetzteilnehmer sind mehrere Laptops und Smartphones.
Eigentlich alles gut, nur irgendwann haben Clients WLAN Zugang aber kein Internetzugriff. Auch dann keinen Zugriff auf die Admin Console von Clients. Vom Raspbian Browser keinen Internet Zugriff. Nach einem Neustart des Pi Hole (bzw Raspberry) läuft es in der Regel wieder. Bis es dann auf einmal nicht mehr geht und ich den Pi Hole manuell neustarten muss (alle paar Stunden/ Pi Hole Admin Console oben link auf Active…).

Meine Gedanken dazu sind:

  • vllt. Raspberry Pi zu heiß? (meistens 55 bis 60°)

  • In der Modemrouterapp werden WLAN Teilnehmer mal gesperrt und entsperrt, da aber statische IP (Modenrouter; MAC Adressen bekamen feste IP) sollte das doch kein Problem sein?

Ich hoffe jemand hat einenn Tipp für mich :slight_smile:
Besten Dank

Verbinbest du dich für einen Neustart per SSH auf den Raspi, oder musst du den Stecker ziehen?

Was für ein Netzteil verwendest du für den Raspi?

Hey

Ich nutze das Original Raspberry Pi 15.3W USB-C Power Supply
Neustarten tue ich direkt am Pi (Monitor, Tastatur angeschlossen) in der Pi Hole Admin Console. Bei den Einstellungen System Neustarten

:slight_smile:

Jetzt mal probiert:
IPv6 im modemrouter deaktiviert.
Pi hole komplett neu aufgesetzt.
DHCP läuft via modemrouter.
Pi hole hat feste IP im modemrouter zugewiesen bekommen.
Es funktioniert, 2… 3 Stunden und dann geht wieder nix mehr, bis ich die PI hole IP im Modemrouter ausgetragen habe um wieder Netz auf den Geräten zu bekommen.
Entweder ist pi hole nicht mehr active (zu sehen oben links admin Console). Oder es funktioniert aus anderen unerklärlichen Gründen nicht (active Status grün)
Jemand ne Idee? Thx

Wieso werden in der Router-App die WLAN-Clients mal geblockt und mal nicht? Wenn die seitens der App/des Routers geblockt werden, haben die natürlich auch keinen Internetzugriff.
Der Pi4 wird gerne etwas heiß, aber 55 - 60 Grad sollten im grünen Bereich sein. Hast du Kühlkörper oder einen Lüfter im Einsatz?
Allerdings scheint der Pi4 generell “etwas zickig” zu sein. Im raspberrypi.org-Forum liest man interessante Geschichten…
Hast du einen anderen Raspi im Zugriff? Bei mir läuft pihole auf einem 3a, und der ist damit schwer unterbeschäftigt :wink:

Huhu :slight_smile:
Habe inzwischen einen Kühlkörper mit aktiver Lüftung. Temp. so um die 38° im Dauerbetrieb.
Zum Verwalten und Maßregeln von jugendlichen Heimnetzteilnehmern werden diese in der TP Link App gesperrt bzw entsperrt. Da sie sonst ihre Hausaufgaben nicht erledigen :slight_smile:
Android 10 Phones benutzen keine wechselnden MAC Adressen (musste ich erst umstellen im Smartphone).
Ich werde gerne Screenshots von Pi Hole Einstellungen und TP Link Modemrouter hier hochladen, hoffentlich wird es weiterhelfen.
Das mit einem anderem Pi zu probieren wäre auch ne Möglichkeit, vllt organisiere ich mir noch einen.

hmm… der Debug Log sagt Folgendes:

Pi Hole Log:

dnsmasq [940] Failed to load names from /etc/pihole/blacklist: no such file or directory

irgendwann wird nicht mehr geblockt und ich muss pi hole aus dns server eintrag des routers entfernen
query log abbruch


handy kein internet

IPv6 ist im Router deaktiviert.
Wenn nix mehr geht, dann kann der Rasp Browser auch nicht mehr auf Internetseiten zugreifen , obwohl WLAN vrbunden
Modemrouter auch nicht mehr via Rasp Browser erreichbar auch obwohl WLAN eingewählt
Der Debug Log macht mir auch sorgen aber kann als Neuling noch nicht viel auswerten

Danke…

Ich weiß nicht mehr weiter :sunny:

Ein in der Tat etwas merkwürdiges Verhalten. Zu deinen Fragezeichen in den Screenshots:
Hinter Adresshaltezeit wird sich sicher die DHCP-Lease-Time verstecken. Das ist die Zeit, die ein DHCP-Server eine einer MAC-Adresse einmal zugewiesene IP für diese MAC vorhält. Danach wird der entsprechende Client den DHCP-Server neu kontaktieren und bekommt normalerweise die selbe IP wieder, sofern er in dem Moment mit dem DHCP-Server auch verbunden sein kann. 24 h kann man machen, aber sind in einem Heimnetz evtl. auch etwas kurzfristig
Die Anzeige mit 00:00:00-1 deutet wohl unbeholfen darauf hin, dass hinter der MAC und der zugehörigen IP ein Client steckt, der eine statische IP hat, die er nicht vom DHCP bezog - jedenfalls sollte der RPi in seiner Rolle als Server besser so konfiguriert sein.

IGMP-Snooping ist eine Funktion auf der Switch-Ebene deines Routers, die ungewollten Multicast-Traffic im lokalen Netzwerk verhindern soll: Beispiel: Falls IPTV bei dir benutzt wird, verhindert IGMP-Snooping, dass die TV Daten an ALLE Netzwerkgeräte gesendet werden, statt nur an den anfordernden Receiver. Wenn Du nicht über Internet fern siehst (MagentaTV und ähnliche Dienste) oder sonst trafficlastige Multicastanwendungen benutzt, kann IGMP-Snooping normalerweise deaktiviert werden. Für den hier beschriebenen Effekt sollte es aber eigentlich nicht verantwortlich sein.

Ich habe unter “DNS/Advanced DNS settings” den Haken bei “Never forward reverse…” rausgenommen.
“Conditional forwarding” ist bei mir auch nicht aktiv.

In Abhängigkeit von der Konfiguration deines Netzwerkes kannst Du dir das leisten. Solange der Router aber der DHCP-Server ist, ist Conditional Forwarding mindestens eine gute Idee, wenn nicht sogar notwendig. Die Frage, ob Reverse Lookups für private Netzwerke weitergereicht werden sollen oder nicht, ist schwieriger zu beantworten. Das sollte primär verhindern, dass solche Anfragen tatsächlich ins Internet gelangen, wo sie nichts zu suchen haben. Es sollte also besser aktiviert sein. Eine Deaktivierung dessen ist nur sinnvoll, wenn dadurch tatsächlich Probleme bei der Auflösung von Hostnamen im LAN behoben werden.

Hast du es denn schon mit pihole -r probiert?

herzlichen Dank für die Antworten.
Werde nach meinem Urlaub darauf zurück kommen :clap:

Problem gelöst

Anderer Raspberry 4 mit derselben Konfiguration macht keine Probleme. Läuft seit 3 Tagen ohne Crash…
Danke Leute :slight_smile: