Pi-hole command not found

#1

I have “pihole: command not found” no pihole executeable is on the machine

0 Likes

How do I update Pi-hole?
#2

You might be on a version before we introduced the pihole command. Try just running the install command again: curl -sSL https://install.pi-hole.net | bash

0 Likes

#3

Thanks it worked, but since the update, at every restart the /etc/resolv.conf reset to nameserver 192.168.0.1 so the dns resolv isn’t works until i write some nameservers in it. Why is that?

0 Likes

#4

It is probably handled by another tool. Check the comments in the file.

0 Likes

#5

i try also curl -sSL https://install.pi-hole.net | bash
pi hole install something, but gui show
Pi-hole Version v2.13.2(Update available!) Web Interface Version v2.5.2(Update available!)

pi is up-to date and i had restart my system

0 Likes

#6

What does the output from

cd /etc/.pihole
sudo git status

Show ?

0 Likes

#7

pi@raspberrypi:~ $ cd /etc/.pihole
pi@raspberrypi:/etc/.pihole $ sudo git status
Auf Branch master
Ihr Branch ist auf dem selben Stand wie ‘origin/master’.
nichts zu committen, Arbeitsverzeichnis unverändert

update works now
perhaps problem with FTL
Pi-hole Version v3.0.1 Web Interface Version v3.0.1 FTL Version (Update available!)

but, with PI Hole 3 the GUI will not update

since 10 minutes the same. browser chache is empty

0 Likes

#8

It doesn’t look like the FTL daemon was installed then. Try pihole -r one last time, and then check

 ls -lach /tmp

And we’ll see if the daemon was pulled down from GitHub.

0 Likes

#9

pi@raspberrypi:/etc/.pihole $ ls -lach /tmp
insgesamt 28K
drwxrwxrwt 7 root root 4,0K Mai 9 20:50 .
drwxr-xr-x 21 root root 4,0K Mär 3 17:18 …
drwxrwxrwt 2 root root 4,0K Mai 9 19:55 .font-unix
drwxrwxrwt 2 root root 4,0K Mai 9 19:55 .ICE-unix
drwxrwxrwt 2 root root 4,0K Mai 9 19:55 .Test-unix
-rw------- 1 root root 0 Mai 9 20:07 tmp.2QxUJihLAH
-rw------- 1 root root 0 Mai 9 20:07 tmp.38jJCinJ3C
-rw------- 1 root root 0 Mai 9 20:07 tmp.bMwnH5egit
-rw------- 1 root root 0 Mai 9 20:08 tmp.h90Cwh9mZM
-rw------- 1 root root 0 Mai 9 20:08 tmp.KIfXipqE4F
-rw------- 1 root root 0 Mai 9 20:08 tmp.NuZ8N6yvdF
-rw------- 1 root root 0 Mai 9 20:08 tmp.RxBl9gI29o
-rw------- 1 root root 0 Mai 9 20:08 tmp.x3jkLDKm3s
-rw------- 1 root root 0 Mai 9 20:08 tmp.yPqgWJacMe
-rw------- 1 root root 0 Mai 9 20:07 tmp.Zl2kT5avOi
drwxrwxrwt 2 root root 4,0K Mai 9 19:55 .X11-unix
drwxrwxrwt 2 root root 4,0K Mai 9 19:55 .XIM-unix

0 Likes

#10

For some reason the binary is not being fetched from the server, it should be in the /tmp directory if you haven’t rebooted since the pihole -r. Can you run the full curl command again, and this time do a curl -sSL https://install.pi-hole.net | sudo bash -x ?

This will be very very verbose, but if you can copy the full output and drop it somewhere like pastebin we can look to see if there’s a failure in the install script.

0 Likes

#11

Hey,
I have the same problem, pihole command not found. I just installed pihole, all went fine and its running. I run
cd /etc/.pihole
sudo git status
here the result:
root@StretchHole:~# cd /etc/.pihole
root@StretchHole:/etc/.pihole# sudo git status
sudo: unable to resolve host StretchHole
On branch master
Your branch is up-to-date with ‘origin/master’.
nothing to commit, working tree clean

PS: I have the “[✗] DNS resolution is currently unavailable” problem too, maybe this cause the line “sudo: unable to resolve host StretchHole”.

I need help.
Regards Stefan

0 Likes

#12

Apologies for necro, but I was having the same issue–pihole: command not found. DanSchaper’s suggestion of curl -sSL https://install.pi-hole.net | sudo bash fixed my issue. I think my problem was that the ‘bash’ command of the default installation procedure () was not elevated and therefore failing. Adding the ‘sudo’ after the pipe let the installer run fine and now pihole is up and running.

Just wanted to let y’all know this helped, in case others are having this problem too.

0 Likes