Pi-hole can't resolve

Expected Behaviour:

Pi-hole can act as my DNS server and resolve domains so that I can use the internet. Also, Pi-hole should be used as DHCP server.

Actual Behaviour:

When I set my pi-hole as our DNS server, no internet services can be used. I can’t browse to any website. I have to set my ISP router to act as DNS for internet to work.

I have looked at similar topics but can’t solve it. I’ve tried disabling dnsmasq, but dnsmasq is not installed on my pi. I’ve tried restarting the DNS resolver, but that doesn’t help. I changed the “Interface listening behavior” to “Listen on all interfaces” but that doesn’t solve it either.

The strange thing is that my pi does have internet connection. If I ping to google.com via cli, the pi can resolve without issues. The problem seems to be with pi-hole rather than with the raspberry pi itself.

Also, I cannot use pi-hole as my DHCP server because then devices aren’t assigned IP addresses.

Debug Token:

https://tricorder.pi-hole.net/w0gjari8h6

Dont forget to restart your router after setting everything up. I had the same problem after setting it up and restarting the router fixed my issue!:slightly_smiling_face:

Done. I’ve set my pi-hole as my DNS server in my router. I configured pi-hole to act as DHCP server and disabled DHCP in my router. After that I restarted the router. I did ipconfig /flushdns on my laptop but since I can use internet I think my laptop is still using the router as DNS. I still don’t see any queries being blocked in pi-hole.

You also need to have your devices setup to use your pi-hole dns. Like on my Windows machine I had to go through and assign it my Pi-Hole dns in order for them to block ads. I also had to do this with my iPhone as well. They both are blocking ads very well.

Tried it again. Now I disabled DHCP in pi-hole and enabled DHCP in the router. In the router I set the DNS server to pi-hole’s IP address. Then internet does not work anymore. So if the pi-hole is my DNS it cannot resolve. I used this guide: How do I configure my devices to use Pi-hole as their DNS server?

It sounds like you had it setup correctly when your Pi-Hole was the DHCP server since you were able to connect, but as far as it not blocking ads i am not sure. I am still new to this project as well.

For me I just had to set my router to use Pi-Hole as DNS and configure my devices to use Pi-Hole as well, every setup is different though. We might need to wait for a moderator or someone who can read your token to chime in. Sorry about that it sounded like you were in the same boat I was.

Your debug log shows that the IP address of the Pi is not receiving traffic. Debug runs a test for this and this is the result in your debug log:

[✗] Failed to resolve kmdl101.com via Pi-hole (192.168.178.99)

Okay so what could be the reason that pi-hole is not receiving any traffic?

Firewall, network failure or a router that has DNS Rebind protection enabled to block any local DNS server from responding to queries as a security measure.

I don’t think it’s because of a firewall or router, because pi-hole worked before when I installed it. I didn’t change anything in my network and it stopped working a while ago.

If Pi-Hole can’t receive traffic on the host device, it can’t process DNS queries, since it can’t receive them. This appears to be an OS level problem - connectivity between the Pi-Hole host and the router.

Pi-hole set on wrong interface ?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.