Pi.hole cannot be found

Expected Behaviour:

I’d expect my systems to route traffic through the pi-hole and be able to access the admin interface through “pi.hole”.

Actual Behaviour:

However, I can’t access pi.hole. I can access the dashboard via the Raspberry Pi’s IP. Ads do not get blocked.

Debug Token:

https://tricorder.pi-hole.net/zlwr250mif

For my setup:

  1. Installed a new raspbian today
  2. Installed pi-hole today
  3. Configured my router to route DNS through the pi-hole. The pi has a static ip (192.168.11.6) which is configured as the only DNS server in my router (192.168.11.1), see figure below.

Initially I had the impression the pi-hole was working. The dashboard showed me a lot of queries and also blocks. But after a reboot (I relocated the hardware to its designated spot) I encounter the problems.

The nslookup also shows an error:

~> nslookup pi.hole 192.168.11.6
Server:		192.168.11.6
Address:	192.168.11.6#53

Name:	pi.hole
Address: 192.168.11.6

 ~> nslookup pi.hole
Server:		192.168.11.1
Address:	192.168.11.1#53

** server can't find pi.hole: NXDOMAIN

I have the gut feeling this is connected to my router settings but I can’t pin it yet.
Reading


Section 1. -> Caveats -> 2. : Is it even possible to reach pi.hole this way? If I understand that post correct, I will not be able to reach the pi-hole without accessing the ip directly.

Works after another restart of all involved systems. Can’t tell why.

A couple of day later the problem returned. This time it was not solved by a restart of the involved systems.
I can access the dashboard via the pi’s IP but not via pi.hole and again the nslookup throws errors and I see ads.

1 Like

If 192.168.11.6 responds with a proper IP for pi.hole then Pi-hole is configured correctly. Not having experience with that particular router I wouldn’t know what settings are needed to have it’s internal DNS correctly forward queries to the Pi-hole.

When the problem is happening are there any queries shown in the admin panel query log? Can you run pihole -d and provide us with the token link so that we can check some basic configuration settings for correctness?

Also check if your router DHCP service dishes out the correct details to its clients using the nmap tool on Pi-hole:

nmap dhcp-discover result:

sudo nmap -sU -p67 --script dhcp-discover 192.168.11.1

Starting Nmap 7.40 ( https://nmap.org ) at 2019-03-18 08:55 GMT
Nmap scan report for 192.168.11.1
Host is up (-0.19s latency).
PORT   STATE         SERVICE
67/udp open|filtered dhcps
MAC Address: XX:24:XX:BC:39:XX (Buffalo.inc)

Nmap done: 1 IP address (1 host up) scanned in 12.47 seconds

Debug token

There are queries showing in the admin panel query log.

I am not sure why nmap isnt able to capture DHCP from your router.
Could be some safety mechanism on the router.
If others dont provide a solution, my advice would be to disable the DHCP service on the router and enable it on Pi-hole:

Well then I’ll probably have to

  • either set the pi manually as my DNS server on each device
  • wait for a new router
  • find out why it worked for one day

I can’t disable DHCP in the router :confused:
Thanks nevertheless for your efforts!

1 Like

image

If you cannot disable DHCP on the router, then change the range of DHCP on the router to one IP address, the IP of the Pi-Hole. Then enable DHCP on the Pi-Hole and assign the range outside the IP of the Pi-Hole.

:roll_eyes: whoops. Thanks!

1 Like

So, after a bit more trial and error I figured a way out to get it working again:

  1. The pi-hole has to be up & running
  2. The router has to be restarted

(in this order!)

It seems as if the the router is up while the pi-hole goes down it relies on a backup DNS that I cannot see or configure via the interface. If the pi-hole gets back up it does not switch to it as DNS server (even if I update the setting for the DNS server IP address). However, restarting the router does the job.
Thanks for all your help so far!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.