Pi Hole blockt keine Werbung im Browser

Guten Tag zusammen,

ich habe heute meinen Pi-Hole in Betrieb genommen und in Verbindung mit der Fritz-Box alles eingetragen.

Allerdings blockt das Ding die Werbung im Browser nicht, weder auf dem Smartphone, noch am PC.

Komischerweise wird die Werbung in den Apps auf dem Smartphone gefiltert. Woran kann das liegen?

Guck mal in deinen Netzwerkeinstellungen ob bei IPV4/6 die Richtige IP drin ist.

Hallo,

Danke erstmal für die Antwort.

Mittlerweile kommen auch in den Apps die Werbeanzeigen wieder durch. Keine Ahnung, wo der Fehler ist.

In der Fritzbox habe ich das PI-Hole als lokalen DNS-Server eingetragen, sowohl unter IPv4 als auch IPv6.

Trotzdem wird keine Werbung blockiert. Andererseits zeigt das Pi Hole in der Benutzeroberfläche eine Blockrate von immerhin 17 Prozent an.

Keine Ahnung, wo der Fehler liegt…

Möglicherweise wissen Deine standfesten Clients (Laptop, PC, etc.) noch nichts von dem neuen DNS-Server. Mitunter bekommen die das erst mit, wenn die Gültigkeit der von der FritzBox vergebenen IP-Adresse abläuft. Standardmässig steht die bei FritzBoxen auf 10 Tagen.

Ob bereits Pi-hole als DNS verwendet wird, kannst Du auf einem solchen Windows-Client auf der Kommandozeile mit ipconfig /all kontrollieren.

Das Ergebnis kann so aussehen (für Details klicken):

Uns interessiert der Teil zur LAN-Verbindung

Ethernet-Adapter LAN-Verbindung:

   Verbindungsspezifisches DNS-Suffix: fritz.box
   Beschreibung. . . . . . . . . . . : Gigabit Ethernet Controller
   Physikalische Adresse . . . . . . : AB-CD-EF-01-23-45
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja
   IPv4-Adresse  . . . . . . . . . . : 192.168.1.10(Bevorzugt)
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Lease erhalten. . . . . . . . . . : Mittwoch, 9. Oktober 2019 08:06:20
   Lease läuft ab. . . . . . . . . . : Freitag, 11. Oktober 2019 08:06:19
   Standardgateway . . . . . . . . . : 192.168.1.1
   DHCP-Server . . . . . . . . . . . : 192.168.1.1
   DNS-Server  . . . . . . . . . . . : 192.168.1.12   <--- Hier muss die IP Deines Pi-holes stehen

Was gibt ipconfig /all auf Deinem PC als DNS-Server aus?

Die Adresse des Pi-Hole (192.168.178.5) wird angezeigt. Habe auch den Windows DNS-Cache mal gelöscht (in der Befehlszeile).

Dann könnte es vielleicht noch daran liegen, dass Dein Browser die DNS-Einstellungen umgeht.
Mit welchem Browser bist Du unterwegs, wenn Du Werbung siehst?

Ich habe 7,8% nur k.a woran das liegt. Ich nutze Opera Browser und habe eine Fritz Box 7490

@Bucking_Horn
Ich verwende auf verschiedenen Geräten verschiedene Browser. Auf dem PC Internet Explorer, Firefox, Chrome. Auf dem Androiden (Smartphone) habe ich es mit Opera, Chrome und verschiedenen Apps getestet.

Ich merke keinen wesentlichen Unterschied zur Nicht-Verwendung des Pi-Holes. Gefühlt gehen gut 85 % der Werbung durch. Aktiviere ich hingegen mein Firefox-Add-Free-Addon auf dem PC oder Blokada auf dem Androiden ist sofort Schluß mit Werbung.

Ich weiß aber nicht warum. Setzte ich eine Domain auf die Blacklist (habe es mit amazon.de mit wildcard gestestet), kann die Seite von keinem der Geräte aufgerufen werden.

Die Standard-Filter habe ich schon bei der Installation geladen und habe noch zig Filter hinzugefügt. Ich weiß nicht mehr weiter.

Im Router habve ich den DNS-Server jetzt noch zusätzlich in den Einstellungen für den DNS-Server eingetragen (sowohl v4 als auch v6) . Bislang hatte ich das nur im Bereich DHCP.

Trotzdem: Es ist alles wie ohne Werbeblocker. Nur: Warum?!

Netzwerkseitig sieht das bei Dir soweit ganz ordentlich aus:

Dein nslookup hat gezeigt, dass Pi-hole von der Fritzbox als DNS-Server verteilt wird.

Und Dein manueller Blacklist-Test zeigt, dass Pi-hole auch Einträge auf Blacklisten wie gewünscht blockt.

Damit hast Du Pi-hole sowohl als lokalen DNS-Server als auch als Upstream-DNS-Server der FritzBox festgelegt. Das ist ok, solange Du im Pi-hole nicht Deine FritzBox als Upstream-DNS-Server eingetragen hast.
Um Dein Heimnetzwerk abzusichern, hätte die Einstellung als lokaler IPv4- und IPv6-DNS-Server unter Heimnetz|Netzwerk|Netzwerkeinstellungen|IPv4-Adressen| Lokaler DNS-Server gereicht.
Die Einstellung als Upstream-DNS in der FritzBox filtert zusätzlich Dein Fritzbox-Gastnetz.
Etwas ausführlicher habe ich diese Einstellungen in Keine Internetverbindung mehr über WLAN Gastzugang Fritzbox verglichen.


Deine IPv6-Einstellungen haben wir jetzt noch nicht kontrolliert.
Wenn da was schief hinge, wären es aber in der Regel hauptsächlich die Smartphones, die Probleme haben. Und das ist nach Deiner Beschreibung nicht der Fall, vielmehr sind bei Dir alle Geräte betroffen

Daher sollten wir zunächst Deine Browsereinstellungen prüfen:

Wenn Du Chrome oder andere chromium-basierte Browser verwendest, kann Dein Browser manchmal Deine netzwerkseitigen DNS-Einstellungen ignorieren und stattdessen Googles DNS-Server verwenden.

Das läßt sich im Browser abschalten (klicken für Beispiele)

You can disable this within the Chrome’s privacy settings.
Look for an option innocently named ‘Use a web service to help resolve navigation errors’:
dns-chrome
In other Chromium based browsers, this option may be named differently.
E.g. Vivaldi chose a more explicit name:
dns-vivaldi


In anderen Chromium-Browsern wie Opera etc. sollte diese Einstellung an ähnlicher Stelle unter Privacy bzw. Datenschutz auftauchen. Das müsstest Du selbst herausfinden.

Hallo,

ja doch, auf dem Smartphone habe ich dasselbe Problem. Anfangs ging es bzw. zumindest hatte ich in einigen Apps keine Werbung.

Jetzt kommt so ziemlich alles durch. Aber die Anfragen müssen ja über den Pi laufen, sonst würde die Blacklkist (testweise “amazon.de” als wildcard) nicht greifen, oder habe ich da einen Denkfehler?

Im Dashboard wird auch eine Blockrate von jetzt mittlerweile 20 Prozent angezeigt. Nur habe ich nicht den Eindruck, daß dort irgendwas geblockt wird.

Wenn ich in der Benutzeroberfläche des Pi-Hole unter “Network” gucke, tauchen auch alle Geräte dort auf, was ja heißen sollte, daß diese auch den Pi-Hole als DNS-Server nutzen, oder?

Kann es sein, daß ich bei den Filterlisten irgendetwas falsch gemacht habe?

Schon geklickt und in Deinen Browsern nachgeschaut?

Tschuldigung. Ja, hatte ich geguckt. Im Feuerfuchs finde ich diese Einstellung nicht.

Heute scheint aber auch schon weniger Werbung angezeigt zu werden. Bekommst Du mit dem Pi-Hole denn sämtliche Werbung weg. Z.B. Auf Focus.de?

Ja, Focus ist bei mir weitgehend (bis auf Mit Gutscheinen online sparen) werbefrei

Firefox basiert ja auch nicht auf Chromium - Opera, Edge und (natürlich)Chrome schon.
Was war in denen denn bei Dir eingestellt? Hast Du die Einstellung dann auch ggf. deaktiviert?

Hhm. Ich finde keine derartige Einstellung.
Ich habe ein paar Listen nachgeladen, so sieht es jetzt sieht es ganz gut aus.

Es scheint auch irgendwie Websitenabhängig zu sein. Ich habe jetzt mal spiegel.de aufgerufen. Da bekomme ich die Werbung mit dem pi hole nicht weg. Schalte ich den AdBlocker des Firefox ein, ist die Werbung veschwunden. Schon alles irgendwie seltsam.

Zumindest in Chrome solltest Du die Einstellung anhand meines Screenshots von oben finden können.

Leider finde ich das auch im Chrome nicht. Ich bekomme unter “Datenschutz und Sicherheit” in den Einstellungen alles mögliche an Einstellungen angeboten, aber nicht die von Dir eingestellte.

Wie gesagt: Es scheint jetzt überwiegend zu funktionieren. Allerdings nicht auf spiegel.de (geht das bei Dir?), auf Focus ist es jetzt ok.

Bei Wetteronline.de wird komischerweise nicht nur die Werbung, sondern geblockt, sondern auch andere Elemente. Dies gilt aber nur für den Browser am PC. Lade ich die Seite auf dem Smartphone, geht es, allerdings hier dann mit Werbung. Verstehe ich auch nicht so ganz.

Die ganze Angelegenheit ist komplizierter als ich dachte.

Pi-hole blockt prinzipiell die Namensauflösung von Domänen, die in einer seiner Blocklisten auftauchen. Was bei Dir oder mir geblockt wird, hängt also von den uns jeweils eingestellten Blocklisten ab. Es macht daher nicht viel Sinn, das Verhalten auf einzelnen Seiten einfach so zu vergleichen.

Das liegt daran, dass Pi-hole auf der Domänen-Ebene blockt.
Ein Browser-Plugin kann auch gezielt URL-Anteile bis zu einzelnen Ressourcen blocken und darüberhinaus auch mit Scriptanteilen differenzierter umgehen, als Pi-hole das kann. Allerdings ist die Wirkung von Plug-Ins genau auf den Browser beschränkt.

Generell ist eine Kombi aus Pihole und Plugin keine schlechte Idee. Pi-hole liefert den Grundschutz für das gesamte Netz, egal ob PC, Smartphone, Drucker, Alexa, etc., und für alle Netzwerkanfragen, nicht nur für den Browser, und Plug-Ins kümmern sich um die Feinsteuerung beim Surfen.

Das könnten wir abgleichen, wenn Du mal ein kleines Bildschirmfoto von Deinen Chrome-Einstellungen hier einfügst.

Blockquote
Pi-hole blockt prinzipiell die Namensauflösung von Domänen, die in einer seiner Blocklisten auftauchen. Was bei Dir oder mir geblockt wird, hängt also von den uns jeweils eingestellten Blocklisten ab. Es macht daher nicht viel Sinn, das Verhalten auf einzelnen Seiten einfach so zu vergleichen.

Naja, das verstehe ich schon. Ich hätte nur ziemlich fest damit gerechnet, daß die Werbung auf spiegel.de schon durch Nutzung der Standard-Listen verschwindet, deshalb wundere ich mich. Die ist tatsächlich nicht wegzubekommen außer mit dem Ad-Blocker-Addon.

OK, aber wieso zeigt die Seite Wetteronline auf dem PC praktisch nichts mehr an, rufe ich hingegen die Seite auf dem Handy im Desktop-Modus auf, schon und zwar einschließlich sämtlicher Werbung. Oder werden da andere Inhalte geladen? Kann ja eigentlich nicht sein, oder?

Wenn eine Seite Werbung über ihre eigene URL ausliefert, kann ein Filter in Pi-hole nur komplett die ganze Seite blocken (aka overblocking), oder eben überhaupt nicht, weshalb dann solche Werbung noch angezeigt wird. Deswegen ist Werbung z.B. auf YouTube nur schwierig zu bändigen. Kann sein, dass das bei Spiegel auch so ist.
Für genau solche Konstellationen ist ein Plug-In gut (wenn ich denn mit der Tatsache leben kann, dass nun ein Plug-In sämtliche meiner Webseiten mitliest und ggf. verändert).

Unterschiedliches Anzeigeverhalten kann sogar auf derselben Maschine in unterschiedlichen Browsern auftreten. Das kann u.U. schon an der JavaScript-Engine liegen. Oft enthalten Webseiten auch Code, der spezifisch für den Browser oder sogar eine bestimmte Browserversion ist und daher unterschiedlich ausfallen kann.
Gerade bei wetteronline.de ist es bei mir mit aktivem Pi-hole und aktiviertem Javascript so, dass die Seite in Vivaldi völlig unbrauchbar ist, während die Darstellung im uralten IE11 halbwegs vernünftig aussieht. Schalte ich uBlock Origin (mit speziellen Einstellungen) zu, sieht’s auch in Vivaldi wieder gut aus.

Dein Screenshot sieht tatsächlich anders aus als die letzte Chrome-Version, die ich bei mir installiert hatte. Letztes Jahr liess sich die Einstellung in einem englischsprachigen Browser noch einfach über chrome://settings/?search=navigation%20errors finden - wird in einem deutschen Browser wohl nicht funktionieren.
Ich würde vermuten, dass das bei Dir vielleicht unter den ersten Punkt “Synchronisierung und Google-Dienste” gewandert ist und da dann auch deutsch heißt (wahrscheinlich was mit nicht aufgelöste Webseiten mit Google auflösen oder ähnlich).

EDIT:
Tatsächlich hat Google mehrere zuvor getrennte Optionen unter "Synchronisierung und Google-Dienste" in eine Option Show suggestions for similar pages when a page can’t be found zusammen geworfen…

Vielen Dank für Deine ausführlichen Erklärungen. Ein bißchen was habe ich verstanden.

Ich verwende jetzt einfach zusätzlich zum Pi Hole noch das Addon im Browser. Und statt wetteronline wetter.com. Das lädt noch. :wink:

Und das Addon bekommt sowohl wetter.com als auch spiegel.de werbefrei. Ich denke, die Kombination aus beidem paßt dann. :wink: